fix LINUX_RELEASE and use it for the kmod-* build
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Aug 2006 13:08:53 +0000 (13:08 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 27 Aug 2006 13:08:53 +0000 (13:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4687 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk
package/kernel/Makefile

index c788bf1..bd558ce 100644 (file)
@@ -16,7 +16,7 @@ else
   # check to see if .kernel.mk matches target.mk
   ifeq ($(CONFIG_BOARD)-$(CONFIG_KERNEL),$(BOARD)-$(KERNEL))
      LINUX_VERSION:=$(CONFIG_LINUX_VERSION)
-     RELEASE:=$(CONFIG_RELEASE)
+     LINUX_RELEASE:=$(CONFIG_LINUX_RELEASE)
   else
   # oops, old .kernel.config; rebuild it (hiding the misleading errors this produces)
     $(warning rebuilding .kernel.mk)
index b59649d..f43f4fd 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=kernel
 PKG_VERSION:=$(LINUX_VERSION)-$(BOARD)
-PKG_RELEASE:=1
+PKG_RELEASE:=$(LINUX_RELEASE)
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/packages