fix kconfig for packages that only define =y, =m or =n rules
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 Aug 2008 21:34:01 +0000 (21:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 27 Aug 2008 21:34:01 +0000 (21:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12414 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index 7d986e4..8393d2f 100644 (file)
@@ -126,7 +126,7 @@ $(call KernelPackage/$(1)/config)
     endef
   endif
 
-  ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+  ifneq ($(if $(filter-out %=y %=n %=m,$(KCONFIG)),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
     ifneq ($(strip $(FILES)),)
       define Package/kmod-$(1)/install
                  mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)