Remove tgz hacks
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Jul 2007 18:50:16 +0000 (18:50 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Jul 2007 18:50:16 +0000 (18:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8066 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/adm5120-2.6/image/Makefile
target/linux/rb532-2.6/image/Makefile

index 829ddef..ee70b6b 100644 (file)
@@ -90,7 +90,6 @@ define Image/Build
 # this line is here intentionally
 ifneq ($(1),jffs2-256k)
 ifneq ($(1),jffs2-128k)
-ifneq ($(1),tgz)
        $(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
 ifeq ($(CONFIG_DEVEL),y)
        $(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
@@ -120,7 +119,6 @@ ifeq ($(CONFIG_DEVEL),y)
 endif
 endif
 endif
-endif
 endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
index a9e2b95..6e2319c 100644 (file)
@@ -56,9 +56,7 @@ endef
 
 define Image/Build
        $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
-ifneq ($(1),tgz)
        ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
-endif
 endef
 
 $(eval $(call BuildImage))