add uclibc portability patch (by thorsten glaser)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 20:03:03 +0000 (20:03 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 20:03:03 +0000 (20:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5034 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/uClibc/patches/150-portability.patch [new file with mode: 0644]

diff --git a/toolchain/uClibc/patches/150-portability.patch b/toolchain/uClibc/patches/150-portability.patch
new file mode 100644 (file)
index 0000000..b29c16e
--- /dev/null
@@ -0,0 +1,38 @@
+Fix portability of build infrastructure
+* cp -d -> cp -P
+* tar --exclude is a GNU tar feature
+
+--- uClibc-0.9.28/Makefile.orig        Sun Jun 11 19:08:56 2006
++++ uClibc-0.9.28/Makefile     Sun Jun 11 19:12:05 2006
+@@ -158,12 +158,7 @@ install_dev:
+       $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)lib
+       $(INSTALL) -d $(PREFIX)$(DEVEL_PREFIX)include
+       -$(INSTALL) -m 644 lib/*.[ao] $(PREFIX)$(DEVEL_PREFIX)lib/
+-      if [ "$(KERNEL_SOURCE)" == "$(DEVEL_PREFIX)" ] ; then \
+-              extra_exclude="--exclude include/linux --exclude include/asm'*'" ; \
+-      else \
+-              extra_exclude="" ; \
+-      fi ; \
+-      tar -chf - include --exclude .svn --exclude CVS $$extra_exclude \
++      tar -chf - include \
+               | tar -xf - -C $(PREFIX)$(DEVEL_PREFIX)
+ ifneq ($(strip $(UCLIBC_HAS_FLOATS)),y)
+       # Remove floating point related headers since float support is disabled.
+@@ -253,7 +248,7 @@ ifeq ($(strip $(HAVE_SHARED)),y)
+       $(INSTALL) -d $(PREFIX)$(RUNTIME_PREFIX)lib
+       $(INSTALL) -m 644 lib/lib*-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so \
+               $(PREFIX)$(RUNTIME_PREFIX)lib
+-      cp -dRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
++      cp -PRf lib/*.so.* $(PREFIX)$(RUNTIME_PREFIX)lib
+       @if [ -x lib/ld-uClibc-$(MAJOR_VERSION).$(MINOR_VERSION).$(SUBLEVEL).so ] ; then \
+           set -e; \
+               $(SHELL_SET_X); \
+@@ -370,7 +365,7 @@ distclean: clean
+ release: distclean
+       cd ..;                                  \
+       $(RM) -r uClibc-$(VERSION);             \
+-      cp -dRf uClibc uClibc-$(VERSION);       \
++      cp -PRf uClibc uClibc-$(VERSION);       \
+       find uClibc-$(VERSION)/ -type f         \
+           -name .\#* -exec $(RM) -r {} \; ;   \
+       find uClibc-$(VERSION)/ -type d         \