Add chan_h323 support for asterisk, closes #122
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Mar 2006 10:46:56 +0000 (10:46 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Mar 2006 10:46:56 +0000 (10:46 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@3447 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile
package/asterisk/Config.in
package/asterisk/Makefile
package/asterisk/ipkg/asterisk-chan-h323.conffiles [new file with mode: 0644]
package/asterisk/ipkg/asterisk-chan-h323.control [new file with mode: 0644]

index d5e42ab..e2d9b3a 100644 (file)
@@ -406,7 +406,7 @@ wx200d-compile: postgresql-compile
 xsupplicant-compile: openssl-compile
 ipsec-tools-compile: openssl-compile
 
-asterisk-compile: bluez-libs-compile ncurses-compile openssl-compile
+asterisk-compile: bluez-libs-compile ncurses-compile openssl-compile openh323-compile
 ifneq ($(BR2_PACKAGE_ASTERISK_CODEC_SPEEX),)
 asterisk-compile: speex-compile
 endif
index dad8cf7..7efaee5 100644 (file)
@@ -21,6 +21,15 @@ config BR2_PACKAGE_ASTERISK_CHAN_BLUETOOTH
        help
          The Bluetooth HandsFreeProfile support for Asterisk
 
+config BR2_PACKAGE_ASTERISK_CHAN_H323
+       prompt  "asterisk-chan-h323.............. H.323 support for Asterisk"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_ASTERISK
+       select BR2_PACKAGE_OPENH323
+       help
+         H.323 support for Asterisk
+
 config BR2_PACKAGE_ASTERISK_CHAN_MGCP
        prompt   "asterisk-chan-mgcp.............. Media Gateway Control Protocol implementation"
        tristate
index eb6edee..015f0cc 100644 (file)
@@ -23,6 +23,7 @@ $(eval $(call PKG_template,ASTERISK_SQLITE,asterisk-sqlite,$(PKG_VERSION)-$(PKG_
 $(eval $(call PKG_template,ASTERISK_VOICEMAIL,asterisk-voicemail,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ASTERISK_SOUNDS,asterisk-sounds,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ASTERISK_CHAN_BLUETOOTH,asterisk-chan-bluetooth,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,ASTERISK_CHAN_H323,asterisk-chan-h323,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ASTERISK_CHAN_MGCP,asterisk-chan-mgcp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ASTERISK_CHAN_SKINNY,asterisk-chan-skinny,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ASTERISK_CODEC_ILBC,asterisk-codec-ilbc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -57,6 +58,21 @@ $(PKG_BUILD_DIR)/.configured:
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
+       (cd $(PKG_BUILD_DIR)/channels/h323/ ; \
+               $(MAKE) \
+               CROSS_ARCH="Linux" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               CROSS_COMPILE_BIN="/void/" \
+               CROSS_COMPILE_TARGET="/void/" \
+               $(TARGET_CONFIGURE_OPTS) \
+               HOST_CC="$(HOSTCC)" \
+               OPTIMIZE="$(TARGET_CFLAGS)" \
+               PROC="$(ARCH)" \
+               DEBUG="" \
+               OPTIONS="-DLOW_MEMORY -Dlinux" \
+               OPENH323DIR=$(BUILD_DIR)/openh323-cvs-20051230 \
+               opt ; \
+       );
        $(MAKE) -C "$(PKG_BUILD_DIR)" \
                CROSS_ARCH="Linux" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
@@ -77,6 +93,8 @@ $(PKG_BUILD_DIR)/.built:
                EXTRA_RES_MODULES="$(EXTRA_RES_MODULES)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                ASTVARLIBDIR="/usr/lib/asterisk" \
+               OPENH323DIR=$(BUILD_DIR)/openh323-cvs-20051230 \
+               PWLIBDIR=$(BUILD_DIR)/pwlib \
                all install samples
        rm -f $(PKG_INSTALL_DIR)/etc/asterisk/*.old
        touch $@
@@ -203,6 +221,14 @@ $(IPKG_ASTERISK_CHAN_BLUETOOTH):
        $(RSTRIP) $(IDIR_ASTERISK_CHAN_BLUETOOTH)
        $(IPKG_BUILD) $(IDIR_ASTERISK_CHAN_BLUETOOTH) $(PACKAGE_DIR)
 
+$(IPKG_ASTERISK_CHAN_H323):
+       install -d -m0755 $(IDIR_ASTERISK_CHAN_H323)/etc/asterisk
+       install -m0644 $(PKG_BUILD_DIR)/channels/h323/h323.conf.sample $(IDIR_ASTERISK_CHAN_H323)/etc/asterisk/h323.conf
+       install -d -m0755 $(IDIR_ASTERISK_CHAN_H323)/usr/lib/asterisk/modules
+       install -m0755 $(PKG_BUILD_DIR)/channels/chan_h323.so $(IDIR_ASTERISK_CHAN_H323)/usr/lib/asterisk/modules/
+       $(RSTRIP) $(IDIR_ASTERISK_CHAN_H323)
+       $(IPKG_BUILD) $(IDIR_ASTERISK_CHAN_H323) $(PACKAGE_DIR)
+
 $(IPKG_ASTERISK_CHAN_MGCP):
        install -d -m0755 $(IDIR_ASTERISK_CHAN_MGCP)/etc/asterisk
        install -m0644 $(PKG_BUILD_DIR)/configs/mgcp.conf.sample $(IDIR_ASTERISK_CHAN_MGCP)/etc/asterisk/mgcp.conf
diff --git a/package/asterisk/ipkg/asterisk-chan-h323.conffiles b/package/asterisk/ipkg/asterisk-chan-h323.conffiles
new file mode 100644 (file)
index 0000000..fc0858a
--- /dev/null
@@ -0,0 +1 @@
+/etc/asterisk/h323.conf
diff --git a/package/asterisk/ipkg/asterisk-chan-h323.control b/package/asterisk/ipkg/asterisk-chan-h323.control
new file mode 100644 (file)
index 0000000..55af6f1
--- /dev/null
@@ -0,0 +1,5 @@
+Package: asterisk-chan-h323
+Priority: optional
+Section: net
+Description: H.323 support for Asterisk
+Depends: asterisk, openh323