[package] globally define IPv6 support or not in OpenWrt, just like for largefiles...
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 25 Jul 2009 21:45:51 +0000 (21:45 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 25 Jul 2009 21:45:51 +0000 (21:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16983 3c298f89-4303-0410-b956-a3cf2f4a3e73

Config.in
include/package-defaults.mk
rules.mk

index d7ce63e..18aafda 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -142,6 +142,13 @@ config DEBUG_DIR
                This will install all compiled package binaries into build_dir/target-*/debug-*/,
                useful for cross-debugging via gdb/gdbserver
 
+config IPV6 
+        bool 
+        prompt "Enable IPv6 support in packages"
+        default n 
+        help 
+                Enable IPV6 support in packages (passes --enable-ipv6 to configure scripts).
+
 comment "Kernel build options"
 
 config KERNEL_KALLSYMS
index 753c102..3cba736 100644 (file)
@@ -60,7 +60,9 @@ CONFIGURE_ARGS = \
                --localstatedir=/var \
                --mandir=$(CONFIGURE_PREFIX)/man \
                --infodir=$(CONFIGURE_PREFIX)/info \
-               $(DISABLE_NLS)
+               $(DISABLE_NLS) \
+               $(DISABLE_LARGEFILE) \
+               $(DISABLE_IPV6)
 
 CONFIGURE_VARS = \
                $(TARGET_CONFIGURE_OPTS) \
index 05609b9..3f39eef 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -153,13 +153,21 @@ else
 endif
 
 ifeq ($(CONFIG_ENABLE_LOCALE),true)
-  DISABLE_NLS:=
+  DISABLE_NLS:=--enable-nls
 else
   DISABLE_NLS:=--disable-nls
 endif
 
-ifneq ($(CONFIG_LARGEFILE),y)
-  DISABLE_LARGEFILE= --disable-largefile
+ifeq ($(CONFIG_IPV6),y)
+  DISABLE_IPV6:=--enable-ipv6
+else
+  DISABLE_IPV6:=--disable-ipv6
+endif
+
+ifeq ($(CONFIG_LARGEFILE),y)
+  DISABLE_LARGEFILE:=
+else
+  DISABLE_LARGEFILE:=--disable-largefile
 endif
 
 ifeq ($(CONFIG_TAR_VERBOSITY),y)