hotplug2: add a missing cflag, allow hotplug events that are not 'add'
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Jun 2007 07:08:35 +0000 (07:08 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Jun 2007 07:08:35 +0000 (07:08 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7721 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hotplug2/Makefile
package/hotplug2/patches/120-action_types.patch [new file with mode: 0644]

index bf7c8c6..c696f09 100644 (file)
@@ -29,7 +29,7 @@ define Package/hotplug2/description
 Hotplug2 is a trivial replacement of some of the UDev functionality
 in a tiny pack, intended for Linux early userspace: Init RAM FS and InitRD.
 endef
-MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
+MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS) -DHAVE_RULES"
 
 define Package/hotplug2/install
        $(INSTALL_DIR) $(1)/etc
diff --git a/package/hotplug2/patches/120-action_types.patch b/package/hotplug2/patches/120-action_types.patch
new file mode 100644 (file)
index 0000000..c81b241
--- /dev/null
@@ -0,0 +1,13 @@
+Index: hotplug2-0.9/hotplug2.c
+===================================================================
+--- hotplug2-0.9.orig/hotplug2.c       2007-06-25 09:07:07.038012616 +0200
++++ hotplug2-0.9/hotplug2.c    2007-06-25 09:07:19.420130248 +0200
+@@ -555,7 +555,7 @@
+               if (cur_seqnum > highest_seqnum)
+                       highest_seqnum = cur_seqnum;
+               
+-              if (tmpevent->action == ACTION_ADD && (!dumb || modalias != NULL)) {
++              if (!dumb || modalias != NULL) {
+                       /* 
+                        * We have more children than we want. Wait until SIGCHLD handler reduces
+                        * their numbers.