[package] base-files: introduce "igmp_snooping" option to toggle IGMP snooping on...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Oct 2011 13:43:08 +0000 (13:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Oct 2011 13:43:08 +0000 (13:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28412 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/network/config.sh

index 713dd7f..6d494e0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=81
+PKG_RELEASE:=82
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index ce8ec89..29d021a 100755 (executable)
@@ -204,8 +204,9 @@ prepare_interface() {
                                        $DEBUG brctl addif "br-$config" "$iface"
                                        # Bridge existed already. No further processing necesary
                                } || {
-                                       local stp
+                                       local stp igmp_snooping
                                        config_get_bool stp "$config" stp 0
+                                       config_get_bool igmp_snooping "$config" igmp_snooping 1
                                        $DEBUG brctl addbr "br-$config"
                                        $DEBUG brctl setfd "br-$config" 0
                                        $DEBUG ifconfig "$iface" 0.0.0.0
@@ -213,6 +214,7 @@ prepare_interface() {
                                        $DEBUG brctl addif "br-$config" "$iface"
                                        $DEBUG brctl stp "br-$config" $stp
                                        [ -z "$macaddr" ] && macaddr="$(cat /sys/class/net/$iface/address)"
+                                       echo $igmp_snooping > /sys/devices/virtual/net/br-$config/bridge/multicast_snooping 2>/dev/null
                                        $DEBUG ifconfig "br-$config" hw ether $macaddr up
                                        # Creating the bridge here will have triggered a hotplug event, which will
                                        # result in another setup_interface() call, so we simply stop processing