include: remove static tool linking support
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Feb 2015 00:00:47 +0000 (00:00 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 6 Feb 2015 00:00:47 +0000 (00:00 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44286 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk
include/prereq-build.mk

index ad821f7..b93f70f 100644 (file)
@@ -73,12 +73,6 @@ HOST_MAKE_FLAGS =
 
 HOST_CONFIGURE_CMD = $(BASH) ./configure
 
-ifneq ($(HOST_OS),Darwin)
-  ifeq ($(CONFIG_BUILD_STATIC_TOOLS),y)
-    HOST_STATIC_LINKING = -static
-  endif
-endif
-
 define Host/Configure/Default
        $(if $(HOST_CONFIGURE_PARALLEL),+)(cd $(HOST_BUILD_DIR)/$(3); \
                if [ -x configure ]; then \
index 306a6b3..1c8de06 100644 (file)
@@ -68,24 +68,6 @@ $(eval $(call TestHostCommand,libssl, \
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
                gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl))
 
-ifneq ($(HOST_STATIC_LINKING),)
-  $(eval $(call TestHostCommand,working-gcc-static, \
-       Please install the static libc development package (glibc-static on CentOS/Fedora/RHEL)., \
-       echo 'int main(int argc, char **argv) { return 0; }' | \
-               gcc -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out -))
-
-  $(eval $(call TestHostCommand,working-g++-static, \
-       Please install the static libstdc++ development package (libstdc++-static on CentOS/Fedora/RHEL)., \
-       echo 'int main(int argc, char **argv) { return 0; }' | \
-               g++ -x c++ $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lstdc++ && \
-               $(TMP_DIR)/a.out))
-
-  $(eval $(call TestHostCommand,zlib-static, \
-       Please install a static zlib. (zlib-static on CentOS/Fedora/RHEL)., \
-       echo 'int main(int argc, char **argv) { gzdopen(0, "rb"); return 0; }' | \
-               gcc -include zlib.h -x c $(HOST_STATIC_LINKING) -o $(TMP_DIR)/a.out - -lz))
-endif
-
 
 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
        gtar --version 2>&1 | grep GNU, \