x86_64 also needs -fPIC to create lua shared libraries
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 10:04:03 +0000 (10:04 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 30 Jul 2008 10:04:03 +0000 (10:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12008 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/lua/Makefile

index 96dda82..d29b323 100644 (file)
@@ -27,6 +27,9 @@ include $(INCLUDE_DIR)/package.mk
 ifeq ($(ARCH),powerpc)
   FPIC:=-fPIC
 endif
+ifeq ($(ARCH),x86_64)
+  FPIC:=-fPIC
+endif
 
 
 define Package/lua/Default