[lantiq] add more profiles
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Nov 2012 19:26:58 +0000 (19:26 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Nov 2012 19:26:58 +0000 (19:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@34131 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/xway/profiles/001-lantiq.mk [deleted file]
target/linux/lantiq/xway/profiles/arv.mk [new file with mode: 0644]
target/linux/lantiq/xway/profiles/lantiq.mk [new file with mode: 0644]

diff --git a/target/linux/lantiq/xway/profiles/001-lantiq.mk b/target/linux/lantiq/xway/profiles/001-lantiq.mk
deleted file mode 100644 (file)
index 6243568..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-define Profile/EASY80920-NOR
-  NAME:=EASY80920-NOR
-endef
-
-define Profile/EASY80920-NOR/Description
-       Lantiq EASY80920 evalkit (NOR)
-endef
-
-$(eval $(call Profile,EASY80920-NOR))
-
-define Profile/EASY80920-NAND
-  NAME:=EASY80920-NAND
-endef
-
-define Profile/EASY80920-NAND/Description
-       Lantiq EASY80920 evalkit (NAND)
-endef
-
-$(eval $(call Profile,EASY80920-NAND))
-
-define Profile/ARV7525PW
-  NAME:=ARV7525PW
-endef
-
-define Profile/ARV7525PW/Description
-       Speedport W303V - ARV7525PW
-endef
-
-$(eval $(call Profile,ARV7525PW))
diff --git a/target/linux/lantiq/xway/profiles/arv.mk b/target/linux/lantiq/xway/profiles/arv.mk
new file mode 100644 (file)
index 0000000..e8d371f
--- /dev/null
@@ -0,0 +1,25 @@
+define Profile/ARV7525PW
+  NAME:=Speedport W303V - ARV7525PW
+endef
+
+$(eval $(call Profile,ARV7525PW))
+
+define Profile/ARV4520PW
+  NAME:=Easybox 800, WAV-281 - ARV4520PW
+endef
+
+$(eval $(call Profile,ARV4520PW))
+
+define Profile/ARV752DPW
+  NAME:=Easybox 802 - ARV752DPW
+endef
+
+$(eval $(call Profile,ARV752DPW))
+
+define Profile/ARV752DPW22
+  NAME:=Easybox 803 - ARV752DPW22
+  PACKAGES:= kmod-usb-core kmod-usb2 kmod-usb-uhci kmod-usb-dwc-otg kmod-ledtrig-usbdev \
+       kmod-ltq-dsl-firmware-b-danube
+endef
+
+$(eval $(call Profile,ARV752DPW22))
diff --git a/target/linux/lantiq/xway/profiles/lantiq.mk b/target/linux/lantiq/xway/profiles/lantiq.mk
new file mode 100644 (file)
index 0000000..2c24d3c
--- /dev/null
@@ -0,0 +1,19 @@
+define Profile/EASY80920-NOR
+  NAME:=EASY80920-NOR
+endef
+
+define Profile/EASY80920-NOR/Description
+       Lantiq EASY80920 evalkit (NOR)
+endef
+
+$(eval $(call Profile,EASY80920-NOR))
+
+define Profile/EASY80920-NAND
+  NAME:=EASY80920-NAND
+endef
+
+define Profile/EASY80920-NAND/Description
+       Lantiq EASY80920 evalkit (NAND)
+endef
+
+$(eval $(call Profile,EASY80920-NAND))