ramips: fix Asus RT-N56U dts filename
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 05:58:35 +0000 (05:58 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 17 Aug 2015 05:58:35 +0000 (05:58 +0000)
Other Asus RT-N dts files are named "RT-N..." (not "RTN..."), so use the same for RT-N56U.

Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46619 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/dts/RT-N56U.dts [new file with mode: 0644]
target/linux/ramips/dts/RTN56U.dts [deleted file]
target/linux/ramips/image/Makefile

diff --git a/target/linux/ramips/dts/RT-N56U.dts b/target/linux/ramips/dts/RT-N56U.dts
new file mode 100644 (file)
index 0000000..3ecd1b7
--- /dev/null
@@ -0,0 +1,151 @@
+/dts-v1/;
+
+/include/ "rt3883.dtsi"
+
+/ {
+       compatible = "RT-N56U", "ralink,rt3883-soc";
+       model = "Asus RT-N56U";
+
+       palmbus@10000000 {
+               gpio1: gpio@638 {
+                       status = "okay";
+               };
+       };
+
+       pinctrl {
+               state_default: pinctrl0 {
+                       gpio {
+                               ralink,group = "spi", "i2c", "jtag", "uartf";
+                               ralink,function = "gpio";
+                       };
+               };
+       };
+
+       ethernet@10100000 {
+               mtd-mac-address = <&factory 0x4>;
+
+               port@0 {
+                       ralink,fixed-link = <1000 1 1 1>;
+               };
+       };
+
+       pci@10140000 {
+               status = "okay";
+               pinctrl-names = "default";
+               pinctrl-0 = <&pci_pins>;
+
+               pci_pins: pci {
+                       pci {
+                               ralink,group = "pci";
+                               ralink,function = "pci-fnc";
+                       };
+               };
+
+               host-bridge {
+                       pci-bridge@1 {
+                               status = "okay";
+
+                               wmac@0,0 {
+                                       compatible = "ralink,rt2880-pci", "pciclass060400", "pciclass0604";
+                                       reg = < 0x10000 0 0 0 0 >;
+                                       ralink,eeprom = "rt2x00pci_1_0.eeprom";
+                               };
+                       };
+               };
+       };
+
+       wmac@10180000 {
+               status = "okay";
+               ralink,2ghz = <0>;
+               ralink,mtd-eeprom = <&factory 0>;
+       };
+
+       ehci@101c0000 {
+               status = "okay";
+       };
+
+       ohci@101c1000 {
+               status = "okay";
+       };
+
+       nor-flash@1c000000 {
+               compatible = "cfi-flash";
+               reg = <0x1c000000 0x800000>;
+               bank-width = <2>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+
+               partition@0 {
+                       reg = <0x0 0x0030000>;
+                       label = "u-boot";
+                       read-only;
+               };
+
+               partition@30000 {
+                       reg = <0x00030000 0x00010000>;
+                       label = "u-boot-env";
+                       read-only;
+               };
+
+               factory: partition@40000 {
+                       reg = <0x00040000 0x00010000>;
+                       label = "factory";
+                       read-only;
+               };
+
+               partition@50000 {
+                       reg = <0x00050000 0x007b0000>;
+                       label = "firmware";
+               };
+       };
+
+       rtl8367 {
+               compatible = "realtek,rtl8367";
+               gpio-sda = <&gpio0 1 0>;
+               gpio-sck = <&gpio0 2 0>;
+               realtek,extif1 = <1 0 1 1 1 1 1 1 2>;
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 13 1>;
+                       linux,code = <0x198>;
+               };
+
+               wps {
+                       label = "wps";
+                       gpios = <&gpio1 2 1>;
+                       linux,code = <0x211>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power {
+                       label = "asus:blue:power";
+                       gpios = <&gpio0 0 1>;
+               };
+
+               lan {
+                       label = "asus:blue:lan";
+                       gpios = <&gpio0 19 1>;
+               };
+
+               wan {
+                       label = "asus:blue:wan";
+                       gpios = <&gpio1 3 1>;
+               };
+
+               usb {
+                       label = "asus:blue:usb";
+                       gpios = <&gpio1 0 1>;
+               };
+       };
+};
diff --git a/target/linux/ramips/dts/RTN56U.dts b/target/linux/ramips/dts/RTN56U.dts
deleted file mode 100644 (file)
index 3ecd1b7..0000000
+++ /dev/null
@@ -1,151 +0,0 @@
-/dts-v1/;
-
-/include/ "rt3883.dtsi"
-
-/ {
-       compatible = "RT-N56U", "ralink,rt3883-soc";
-       model = "Asus RT-N56U";
-
-       palmbus@10000000 {
-               gpio1: gpio@638 {
-                       status = "okay";
-               };
-       };
-
-       pinctrl {
-               state_default: pinctrl0 {
-                       gpio {
-                               ralink,group = "spi", "i2c", "jtag", "uartf";
-                               ralink,function = "gpio";
-                       };
-               };
-       };
-
-       ethernet@10100000 {
-               mtd-mac-address = <&factory 0x4>;
-
-               port@0 {
-                       ralink,fixed-link = <1000 1 1 1>;
-               };
-       };
-
-       pci@10140000 {
-               status = "okay";
-               pinctrl-names = "default";
-               pinctrl-0 = <&pci_pins>;
-
-               pci_pins: pci {
-                       pci {
-                               ralink,group = "pci";
-                               ralink,function = "pci-fnc";
-                       };
-               };
-
-               host-bridge {
-                       pci-bridge@1 {
-                               status = "okay";
-
-                               wmac@0,0 {
-                                       compatible = "ralink,rt2880-pci", "pciclass060400", "pciclass0604";
-                                       reg = < 0x10000 0 0 0 0 >;
-                                       ralink,eeprom = "rt2x00pci_1_0.eeprom";
-                               };
-                       };
-               };
-       };
-
-       wmac@10180000 {
-               status = "okay";
-               ralink,2ghz = <0>;
-               ralink,mtd-eeprom = <&factory 0>;
-       };
-
-       ehci@101c0000 {
-               status = "okay";
-       };
-
-       ohci@101c1000 {
-               status = "okay";
-       };
-
-       nor-flash@1c000000 {
-               compatible = "cfi-flash";
-               reg = <0x1c000000 0x800000>;
-               bank-width = <2>;
-               #address-cells = <1>;
-               #size-cells = <1>;
-
-               partition@0 {
-                       reg = <0x0 0x0030000>;
-                       label = "u-boot";
-                       read-only;
-               };
-
-               partition@30000 {
-                       reg = <0x00030000 0x00010000>;
-                       label = "u-boot-env";
-                       read-only;
-               };
-
-               factory: partition@40000 {
-                       reg = <0x00040000 0x00010000>;
-                       label = "factory";
-                       read-only;
-               };
-
-               partition@50000 {
-                       reg = <0x00050000 0x007b0000>;
-                       label = "firmware";
-               };
-       };
-
-       rtl8367 {
-               compatible = "realtek,rtl8367";
-               gpio-sda = <&gpio0 1 0>;
-               gpio-sck = <&gpio0 2 0>;
-               realtek,extif1 = <1 0 1 1 1 1 1 1 2>;
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <100>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 13 1>;
-                       linux,code = <0x198>;
-               };
-
-               wps {
-                       label = "wps";
-                       gpios = <&gpio1 2 1>;
-                       linux,code = <0x211>;
-               };
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               power {
-                       label = "asus:blue:power";
-                       gpios = <&gpio0 0 1>;
-               };
-
-               lan {
-                       label = "asus:blue:lan";
-                       gpios = <&gpio0 19 1>;
-               };
-
-               wan {
-                       label = "asus:blue:wan";
-                       gpios = <&gpio1 3 1>;
-               };
-
-               usb {
-                       label = "asus:blue:usb";
-                       gpios = <&gpio1 0 1>;
-               };
-       };
-};
index 232742c..5e749e6 100644 (file)
@@ -819,12 +819,12 @@ omniembhpm_mtd_size=16449536
 Image/Build/Profile/OMNIEMBHPM=$(call BuildFirmware/CustomFlash/$(1),$(1),omni-emb-hpm,OMNI-EMB-HPM,$(omniembhpm_mtd_size))
 
 define BuildFirmware/RTN56U/squashfs
-       $(call BuildFirmware/Default8M/$(1),$(1),rt-n56u,RTN56U)
+       $(call BuildFirmware/Default8M/$(1),$(1),rt-n56u,RT-N56U)
        -mkrtn56uimg -s $(call sysupname,$(1),rt-n56u)
        -cp $(call sysupname,$(1),rt-n56u) $(call imgname,$(1),rt-n56u)-factory.bin
        -mkrtn56uimg -f $(call imgname,$(1),rt-n56u)-factory.bin
 endef
-Image/Build/Profile/RTN56U=$(call BuildFirmware/RTN56U/$(1),$(1),rt-n56u,RTN56U)
+Image/Build/Profile/RTN56U=$(call BuildFirmware/RTN56U/$(1),$(1),rt-n56u,RT-N56U)
 
 Image/Build/Profile/TEW691GR=$(call BuildFirmware/UMedia/$(1),$(1),tew-691gr,TEW-691GR,0x026910)