update gs v4 pattern so that the latest linksys firmware accepts it
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 15 Dec 2005 01:11:38 +0000 (01:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 15 Dec 2005 01:11:38 +0000 (01:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2678 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/image/brcm/Makefile
target/utils/src/addpattern.c

index 530dd1e..49c94f6 100644 (file)
@@ -54,7 +54,7 @@ $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$
        $(STAGING_DIR)/bin/addpattern -4 -p W54G -v v4.20.6 -i $< -o $@ -g
 
 $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
-       $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.0 -i $< -o $@ -g
+       $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.2 -i $< -o $@ -g
 
 install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin
 endif
@@ -78,7 +78,7 @@ $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$
        $(STAGING_DIR)/bin/addpattern -4 -p W54G -v v4.20.6 -i $< -o $@ -g
 
 $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin: $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(FS).trx
-       $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.0 -i $< -o $@ -g
+       $(STAGING_DIR)/bin/addpattern -4 -p W54s -v v1.05.2 -i $< -o $@ -g
 
 install: $(BIN_DIR)/openwrt-wrt54g-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54gs_v4-$(KERNEL)-$(FSNAME).bin $(BIN_DIR)/openwrt-wrt54g3g-$(KERNEL)-$(FSNAME).bin
 endif
index 67f9da2..9962a67 100644 (file)
@@ -138,7 +138,7 @@ int main(int argc, char **argv)
                                break;
                        case '4':
                                /* V4 firmware sets the flags to 0x1f */
-                               hdr->hw_ver = 1;
+                               hdr->hw_ver = 0;
                                hdr->flags = 0x1f;
                                break;