hostapd: move old wifi setup scripts to hostapd-common-old
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Dec 2013 18:42:43 +0000 (18:42 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Dec 2013 18:42:43 +0000 (18:42 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39103 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/hostap-driver/Makefile
package/network/services/hostapd/Makefile

index 6a95c1e..87c854c 100644 (file)
@@ -34,7 +34,7 @@ endef
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP support for Prism2/2.5/3
 define KernelPackage/hostap
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP support for Prism2/2.5/3
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-lib80211 +wireless-tools
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-lib80211 +wireless-tools +hostapd-common-old
   KCONFIG:=CONFIG_HOSTAP CONFIG_HOSTAP_FIRMWARE=y CONFIG_HOSTAP_FIRMWARE_NVRAM=y
   FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap.ko
   AUTOLOAD:=$(call AutoProbe,hostap)
   KCONFIG:=CONFIG_HOSTAP CONFIG_HOSTAP_FIRMWARE=y CONFIG_HOSTAP_FIRMWARE_NVRAM=y
   FILES:=$(LINUX_DIR)/drivers/net/wireless/hostap/hostap.ko
   AUTOLOAD:=$(call AutoProbe,hostap)
index 05a74bb..f00472a 100644 (file)
@@ -214,6 +214,12 @@ define Package/hostapd-common
   CATEGORY:=Network
 endef
 
   CATEGORY:=Network
 endef
 
+define Package/hostapd-common-old
+  TITLE:=hostapd/wpa_supplicant common support files (legacy drivers)
+  SECTION:=net
+  CATEGORY:=Network
+endef
+
 ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
   define Build/Configure/rebuild
        $(FIND) $(PKG_BUILD_DIR) -name \*.o -or -name \*.a | $(XARGS) rm -f
 ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
   define Build/Configure/rebuild
        $(FIND) $(PKG_BUILD_DIR) -name \*.o -or -name \*.a | $(XARGS) rm -f
@@ -303,14 +309,10 @@ define Build/Compile
 endef
 
 define Install/hostapd
 endef
 
 define Install/hostapd
-       $(INSTALL_DIR) $(1)/lib/wifi
-       $(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/wifi/hostapd.sh
        $(INSTALL_DIR) $(1)/usr/sbin
 endef
 
 define Install/supplicant
        $(INSTALL_DIR) $(1)/usr/sbin
 endef
 
 define Install/supplicant
-       $(INSTALL_DIR) $(1)/lib/wifi
-       $(INSTALL_DATA) ./files/wpa_supplicant.sh $(1)/lib/wifi/wpa_supplicant.sh
        $(INSTALL_DIR) $(1)/usr/sbin
 endef
 
        $(INSTALL_DIR) $(1)/usr/sbin
 endef
 
@@ -319,6 +321,12 @@ define Package/hostapd-common/install
        $(INSTALL_DATA) ./files/netifd.sh $(1)/lib/netifd/hostapd.sh
 endef
 
        $(INSTALL_DATA) ./files/netifd.sh $(1)/lib/netifd/hostapd.sh
 endef
 
+define Package/hostapd-common-old/install
+       $(INSTALL_DIR) $(1)/lib/wifi
+       $(INSTALL_DATA) ./files/hostapd.sh $(1)/lib/wifi/hostapd.sh
+       $(INSTALL_DATA) ./files/wpa_supplicant.sh $(1)/lib/wifi/wpa_supplicant.sh
+endef
+
 define Package/hostapd/install
        $(call Install/hostapd,$(1))
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
 define Package/hostapd/install
        $(call Install/hostapd,$(1))
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
@@ -366,3 +374,4 @@ $(eval $(call BuildPackage,wpa-supplicant-p2p))
 $(eval $(call BuildPackage,wpa-cli))
 $(eval $(call BuildPackage,hostapd-utils))
 $(eval $(call BuildPackage,hostapd-common))
 $(eval $(call BuildPackage,wpa-cli))
 $(eval $(call BuildPackage,hostapd-utils))
 $(eval $(call BuildPackage,hostapd-common))
+$(eval $(call BuildPackage,hostapd-common-old))