kernel: kmod-appletalk: fix dependencies
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 09:51:07 +0000 (09:51 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Aug 2013 09:51:07 +0000 (09:51 +0000)
When CONFIG_LLC gets build as a module, also p8022.ko and psnap.ko are
getting build as a module. kmod-appletalk depends on llc.ko and
psnap.ko, but at least psnap.ko,was not packed. On most systems
CONFIG_LLC will be build into the kernel so this problem does not show
up.

This fixes the missing dependency of kmod-appletalk on psnap.ko

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37673 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netsupport.mk

index cf31f28..da84ab8 100644 (file)
@@ -45,6 +45,7 @@ $(eval $(call KernelPackage,atmtcp))
 define KernelPackage/appletalk
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Appletalk protocol support
+  DEPENDS:=+PACKAGE_kmod-llc:kmod-llc
   KCONFIG:= \
        CONFIG_ATALK \
        CONFIG_DEV_APPLETALK \
@@ -100,8 +101,11 @@ define KernelPackage/llc
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=ANSI/IEEE 802.2 LLC support
   KCONFIG:=CONFIG_LLC
-  FILES:=$(LINUX_DIR)/net/llc/llc.ko
-  AUTOLOAD:=$(call AutoLoad,09,llc)
+  FILES:= \
+       $(LINUX_DIR)/net/llc/llc.ko \
+       $(LINUX_DIR)/net/802/p8022.ko \
+       $(LINUX_DIR)/net/802/psnap.ko
+  AUTOLOAD:=$(call AutoLoad,09,llc p8022 psnap)
 endef
 
 define KernelPackage/llc/description