kernel build cleanup
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 17:24:20 +0000 (17:24 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 2 Mar 2007 17:24:20 +0000 (17:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6464 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk
include/kernel-build.mk
target/linux/atheros-2.6/image/Makefile
target/linux/rb532-2.6/image/Makefile

index 9c170af..78e1a2f 100644 (file)
@@ -61,8 +61,10 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
                tar -zcf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-rootfs.tgz --owner=root --group=root -C $(BUILD_DIR)/root/ .
     endef
   endif
-  
-  
+else
+  define Image/BuildKernel
+       cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
+  endef
 endif
 
 
index 6aec7c7..3a17182 100644 (file)
@@ -136,6 +136,7 @@ define Kernel/CompileImage/Default
        $(call Kernel/SetInitramfs)
        $(MAKE) -j$(CONFIG_JLEVEL) $(KERNEL_MAKEOPTS) CC="$(KERNEL_CC)" $(KERNELNAME)
        $(KERNEL_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(LINUX_KERNEL)
+       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
 endef
 define Kernel/CompileImage
        $(call Kernel/CompileImage/Default)
index dfd1746..1d32a4b 100644 (file)
@@ -7,10 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Image/Prepare
-       cp $(KDIR)/linux-*/vmlinux $(KDIR)/vmlinux.elf
-endef
-
 define Image/BuildKernel
        cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux.elf
        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
index b35b0b1..e6794c0 100644 (file)
@@ -31,7 +31,6 @@ endef
 define Image/Prepare
        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
        $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
-       $(KERNEL_CROSS)objcopy -R .reginfo -R .note -R .comment -R .mdebug -S $(LINUX_DIR)/vmlinux $(KDIR)/vmlinux.elf
 endef
 
 define Image/BuildKernel