[package] uboot-imx6: update to 2014.04
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 May 2014 21:01:18 +0000 (21:01 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 May 2014 21:01:18 +0000 (21:01 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40805 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/uboot-imx6/Makefile
package/boot/uboot-imx6/patches/100-wandboard-enable-fit.patch
package/boot/uboot-imx6/patches/110-wandboard-owrt-env.patch

index 0c989f3..7074da9 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=u-boot
-PKG_VERSION:=2013.10
+PKG_VERSION:=2014.04
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -16,7 +16,9 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        http://mirror2.openwrt.org/sources \
        ftp://ftp.denx.de/pub/u-boot
-PKG_MD5SUM:=a076a044b64371edc52f7e562b13f6b2
+PKG_MD5SUM:=6d2116d1385a66e9a59742caa9d62a54
+
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -98,11 +100,13 @@ UBOOT_IMAGE:=$(if $(IMAGE),$(IMAGE),openwrt-$(BOARD)-$(BUILD_VARIANT)-u-boot.bin
 endif
 
 define Build/Configure
-       $(MAKE) -C $(PKG_BUILD_DIR) $(UBOOT_CONFIG)_config
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               $(UBOOT_CONFIG)_config
 endef
 
 define Build/Compile
-       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) CROSS_COMPILE=$(TARGET_CROSS)
+       +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
+               CROSS_COMPILE=$(TARGET_CROSS)
 endef
 
 define Package/uboot/install/default
index f847c5a..894ccf0 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/wandboard.h
 +++ b/include/configs/wandboard.h
-@@ -242,4 +242,7 @@
+@@ -238,4 +238,7 @@
  #define CONFIG_CMD_CACHE
  #endif
  
index 9357892..7bef453 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/configs/wandboard.h
 +++ b/include/configs/wandboard.h
-@@ -48,7 +48,7 @@
+@@ -49,7 +49,7 @@
  #define CONFIG_CMD_BMODE
  #define CONFIG_CMD_SETEXPR
  
@@ -9,24 +9,24 @@
  
  #define CONFIG_SYS_MEMTEST_START      0x10000000
  #define CONFIG_SYS_MEMTEST_END                (CONFIG_SYS_MEMTEST_START + 500 * SZ_1M)
-@@ -101,13 +101,15 @@
+@@ -102,13 +102,15 @@
  
  #if defined(CONFIG_MX6DL) || defined(CONFIG_MX6S)
  #define CONFIG_DEFAULT_FDT_FILE               "imx6dl-wandboard.dtb"
-+#define CONFIG_OWRT_NAME              "openwrt-imx6-imx6dl-wandboard-fit-uImage.itb"
++#define CONFIG_OWRT_NAME "openwrt-imx6-imx6dl-wandboard-fit-uImage.itb"
  #elif defined(CONFIG_MX6Q)
  #define CONFIG_DEFAULT_FDT_FILE               "imx6q-wandboard.dtb"
-+#define CONFIG_OWRT_NAME              "openwrt-imx6-imx6q-wandboard-fit-uImage.itb"
++#define CONFIG_OWRT_NAME "openwrt-imx6-imx6q-wandboard-fit-uImage.itb"
  #endif
  
  #define CONFIG_EXTRA_ENV_SETTINGS \
        "script=boot.scr\0" \
--      "uimage=uImage\0" \
-+      "uimage=" CONFIG_OWRT_NAME "\0" \
+-      "image=zImage\0" \
++      "image=" CONFIG_OWRT_NAME "\0" \
        "console=ttymxc0\0" \
        "splashpos=m,m\0" \
        "fdt_high=0xffffffff\0" \
-@@ -136,11 +138,11 @@
+@@ -137,11 +139,11 @@
        "mmcargs=setenv bootargs console=${console},${baudrate} " \
                "root=${mmcroot}\0" \
        "loadbootscript=" \
 +              "ext2load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
        "bootscript=echo Running bootscript from mmc ...; " \
                "source\0" \
--      "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
+-      "loadimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${image}\0" \
 -      "loadfdt=fatload mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \
 +      "loaduimage=ext2load mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
 +      "loadfdt=ext2load mmc ${mmcdev}:${mmcpart} ${fdt_addr} ${fdt_file}\0" \
        "mmcboot=echo Booting from mmc ...; " \
                "run mmcargs; " \
                "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
-@@ -155,30 +157,6 @@
+@@ -155,31 +157,7 @@
+                               "fi; " \
                        "fi; " \
                "else " \
-                       "bootm; " \
+-                      "bootz; " \
 -              "fi;\0" \
 -      "netargs=setenv bootargs console=${console},${baudrate} " \
 -              "root=/dev/nfs " \
 -              "else " \
 -                      "setenv get_cmd tftp; " \
 -              "fi; " \
--              "${get_cmd} ${uimage}; " \
+-              "${get_cmd} ${image}; " \
 -              "if test ${boot_fdt} = yes || test ${boot_fdt} = try; then " \
 -                      "if ${get_cmd} ${fdt_addr} ${fdt_file}; then " \
--                              "bootm ${loadaddr} - ${fdt_addr}; " \
+-                              "bootz ${loadaddr} - ${fdt_addr}; " \
 -                      "else " \
 -                              "if test ${boot_fdt} = try; then " \
--                                      "bootm; " \
+-                                      "bootz; " \
 -                              "else " \
 -                                      "echo WARN: Cannot load the DT; " \
 -                              "fi; " \
 -                      "fi; " \
 -              "else " \
--                      "bootm; " \
+-                      "bootz; " \
++                      "bootm; " \
                "fi;\0"
  
  #define CONFIG_BOOTCOMMAND \
-@@ -188,10 +166,10 @@
+@@ -189,10 +167,10 @@
                   "else " \
-                          "if run loaduimage; then " \
+                          "if run loadimage; then " \
                                   "run mmcboot; " \
 -                         "else run netboot; " \
 +                         "else echo WARN: Can not boot the image; " \