lua: enable parallel builds
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Oct 2012 20:48:31 +0000 (20:48 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Oct 2012 20:48:31 +0000 (20:48 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33716 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/lua/Makefile

index c5df4d5..fca7747 100644 (file)
@@ -17,6 +17,7 @@ PKG_SOURCE_URL:=http://www.lua.org/ftp/ \
        http://mirrors.dotsrc.org/lua/ \
        http://www.tecgraf.puc-rio.br/lua/ftp/
 PKG_MD5SUM:=2e115fe26e435e33b0d5c022e4490567
        http://mirrors.dotsrc.org/lua/ \
        http://www.tecgraf.puc-rio.br/lua/ftp/
 PKG_MD5SUM:=2e115fe26e435e33b0d5c022e4490567
+PKG_BUILD_PARALLEL:=1
 
 HOST_PATCH_DIR := ./patches-host
 
 
 HOST_PATCH_DIR := ./patches-host
 
@@ -96,7 +97,7 @@ ifneq ($(CONFIG_USE_EGLIBC),)
 endif
 
 define Build/Compile
 endif
 
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) \
+       $(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CROSS)gcc" \
                AR="$(TARGET_CROSS)ar rcu" \
                RANLIB="$(TARGET_CROSS)ranlib" \
                CC="$(TARGET_CROSS)gcc" \
                AR="$(TARGET_CROSS)ar rcu" \
                RANLIB="$(TARGET_CROSS)ranlib" \