move libnotimpl to /packages/libs, fix another typo in ./src/math.c
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Oct 2006 11:29:54 +0000 (11:29 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Oct 2006 11:29:54 +0000 (11:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5355 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/libnotimpl/Makefile [deleted file]
toolchain/libnotimpl/src/math.c [deleted file]

diff --git a/toolchain/libnotimpl/Makefile b/toolchain/libnotimpl/Makefile
deleted file mode 100644 (file)
index 8515672..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=libnotimpl
-
-PKG_BUILD_DIR:=$(TOOLCHAIN_BUILD_DIR)/libnotimpl
-
-include $(INCLUDE_DIR)/host-build.mk
-
-define cc
-       $(TARGET_CC) $(TARGET_CFLAGS) -c src/$(1).c -o $(PKG_BUILD_DIR)/$(1).o
-endef
-
-define Build/Prepare
-       rm -rf $(PKG_BUILD_DIR)
-       mkdir -p $(PKG_BUILD_DIR)
-endef
-
-define Build/Compile
-       $(call cc,math)
-       $(TARGET_CROSS)ar rc $(PKG_BUILD_DIR)/libnotimpl.a $(PKG_BUILD_DIR)/*.o
-endef
-
-define Build/Install
-       mkdir -p $(STAGING_DIR)/usr/lib
-       $(CP) $(PKG_BUILD_DIR)/libnotimpl.a $(STAGING_DIR)/usr/lib/
-endef
-
-define Build/Clean
-       rm -f $(STAGING_DIR)/usr/lib/libnotimpl.a
-endef
-
-$(eval $(call HostBuild))
-
diff --git a/toolchain/libnotimpl/src/math.c b/toolchain/libnotimpl/src/math.c
deleted file mode 100644 (file)
index 5bfcb95..0000000
+++ /dev/null
@@ -1,68 +0,0 @@
-/* vi: set sw=4 ts=4: */
-
-#include "math.h"
-
-
-/* cosf for uClibc
- *
- * wrapper for cos(x)
- */
-
-#ifdef __STDC__
-       float cosf(float x)
-#else
-       float cosf(x)
-       float x;
-#endif
-{
-       return (float) cos( (double)x );
-}
-
-
-/* sinf for uClibc
- *
- * wrapper for sin(x)
- */
-
-#ifdef __STDC__
-       float sinf(float x)
-#else
-       float sinf(x)
-       float x;
-#endif
-{
-       return (float) sin( (double)x );
-}
-
-
-/* ceilf for uClibc
- *
- * wrapper for ceil(x)
- */
-
-#ifdef __STDC__
-       float ceilf(float x)
-#else
-       float ceilf(x)
-       float x;
-#endif
-{
-       return (float) ceil( (double)x );
-}
-
-
-/* rintf for uClibc
- *
- * wrapper for rint(x)
- */
-
-#ifdef __STDC__
-       float rintf(float x)
-#else
-       float rintf(x)
-       float x;
-#endif
-{
-       return (float) sin( (double)x );
-}
-