build: remove check to nonexistant CONFIG_ENABLE_LOCALE variable and move DISABLE_NLS...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Mar 2014 15:54:07 +0000 (15:54 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Mar 2014 15:54:07 +0000 (15:54 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39980 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package-defaults.mk
rules.mk
toolchain/gdb/Makefile
toolchain/insight/Makefile

index 62ccbb9..8f35c32 100644 (file)
@@ -64,6 +64,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
 endif
 
 EXTRA_CXXFLAGS = $(EXTRA_CFLAGS)
+DISABLE_NLS:=--disable-nls
 
 CONFIGURE_PREFIX:=/usr
 CONFIGURE_ARGS = \
index 0769a09..cc02b91 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -260,12 +260,6 @@ else
     $(SCRIPT_DIR)/rstrip.sh
 endif
 
-ifeq ($(CONFIG_ENABLE_LOCALE),true)
-  DISABLE_NLS:=--enable-nls
-else
-  DISABLE_NLS:=--disable-nls
-endif
-
 ifeq ($(CONFIG_IPV6),y)
   DISABLE_IPV6:=
 else
index 627baff..10de1f8 100644 (file)
@@ -29,7 +29,6 @@ define Host/Configure
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
                --disable-werror \
-               $(DISABLE_NLS) \
                --without-uiout \
                --disable-tui --disable-gdbtk --without-x \
                --without-included-gettext \
index 9fb39e1..3744f56 100644 (file)
@@ -28,7 +28,6 @@ define Host/Configure
                --build=$(GNU_HOST_NAME) \
                --host=$(GNU_HOST_NAME) \
                --target=$(REAL_GNU_TARGET_NAME) \
-               $(DISABLE_NLS) \
                --enable-threads \
                --enable-werror=no \
        );