build: add @APACHE download facility
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jan 2016 10:47:32 +0000 (10:47 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jan 2016 10:47:32 +0000 (10:47 +0000)
The Apache Software Foundation offers diverse download mirros.

For packaging Apache software a new alias @APACHE is defined.

Signed-off-by: Heinrich Schuchardt <xypron.glpk@gmx.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48270 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/download.mk
scripts/download.pl

index 8a1205d..ca5eee4 100644 (file)
@@ -13,7 +13,7 @@ DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 define dl_method
 $(strip \
   $(if $(2),$(2), \
-    $(if $(filter @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
+    $(if $(filter @APACHE/% @GNOME/% @GNU/% @KERNEL/% @SF/% @SAVANNAH/% ftp://% http://% https://% file://%,$(1)),default, \
       $(if $(filter git://%,$(1)),git, \
         $(if $(filter svn://%,$(1)),svn, \
           $(if $(filter cvs://%,$(1)),cvs, \
index 9d1fe47..25c73fb 100755 (executable)
@@ -176,6 +176,12 @@ foreach my $mirror (@ARGV) {
                for (1 .. 5) {
                        push @mirrors, "http://downloads.sourceforge.net/$1";
                }
+       } elsif ($mirror =~ /^\@APACHE\/(.+)$/) {
+               push @mirrors, "http://ftp.tudelft.nl/apache/$1";
+               push @mirrors, "http://apache.openmirror.de/$1";
+               push @mirrors, "http://mirrors.ocf.berkeley.edu/apache/$1";
+               push @mirrors, "http://mirror.cc.columbia.edu/pub/software/apache/$1";
+               push @mirrors, "http://ftp.jaist.ac.jp/pub/apache/$1";
        } elsif ($mirror =~ /^\@GNU\/(.+)$/) {
                push @mirrors, "http://ftpmirror.gnu.org/$1";
                push @mirrors, "http://ftp.gnu.org/pub/gnu/$1";