include: modify kernel.mk to build empty kmod packages if the referenced symbols...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 15:41:09 +0000 (15:41 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jul 2013 15:41:09 +0000 (15:41 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37400 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index cbf342a..5442c91 100644 (file)
@@ -176,9 +176,13 @@ $(call KernelPackage/$(1)/config)
     endif
   $(if $(CONFIG_PACKAGE_kmod-$(1)),
     else
-      compile: kmod-$(1)-unavailable
-      kmod-$(1)-unavailable:
-               @echo "WARNING: kmod-$(1) is not available in the kernel config" >&2
+      compile: $(1)-disabled
+      $(1)-disabled:
+               @echo "WARNING: kmod-$(1) is not available in the kernel config - generating empty package" >&2
+
+      define Package/kmod-$(1)/install
+               true
+      endef
   )
   endif
   $$(eval $$(call BuildPackage,kmod-$(1)))