kernel: update 3.14 to 3.14.5
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 09:25:33 +0000 (09:25 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Jun 2014 09:25:33 +0000 (09:25 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40901 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-3.14/100-overlayfs.patch
target/linux/generic/patches-3.14/644-bridge_optimize_netfilter_hooks.patch
target/linux/generic/patches-3.14/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-3.14/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch
target/linux/generic/patches-3.14/721-phy_packets.patch
target/linux/generic/patches-3.14/903-debloat_direct_io.patch
target/linux/x86_64/Makefile

index c1bb456..bc42b02 100644 (file)
@@ -23,8 +23,8 @@ endif
 ifeq ($(LINUX_VERSION),3.13.7)
   LINUX_KERNEL_MD5SUM:=370adced5e5c1cb1d0d621c2dae2723f
 endif
-ifeq ($(LINUX_VERSION),3.14.4)
-  LINUX_KERNEL_MD5SUM:=c7c565d14833550faa39ef8279272182
+ifeq ($(LINUX_VERSION),3.14.5)
+  LINUX_KERNEL_MD5SUM:=db2f2b8a83239852b72e560811eb80de
 endif
 
 # disable the md5sum check for unknown kernel versions
index 218b5c8..28bd4d8 100644 (file)
  {
 --- a/fs/open.c
 +++ b/fs/open.c
-@@ -834,8 +834,7 @@ struct file *dentry_open(const struct pa
+@@ -822,8 +822,7 @@ struct file *dentry_open(const struct pa
        f = get_empty_filp();
        if (!IS_ERR(f)) {
                f->f_flags = flags;
                if (!error) {
                        /* from now on we need fput() to dispose of f */
                        error = open_check_o_direct(f);
-@@ -852,6 +851,26 @@ struct file *dentry_open(const struct pa
+@@ -840,6 +839,26 @@ struct file *dentry_open(const struct pa
  }
  EXPORT_SYMBOL(dentry_open);
  
index 3af45ec..d803af7 100644 (file)
  
 --- a/net/bridge/netfilter/ebtables.c
 +++ b/net/bridge/netfilter/ebtables.c
-@@ -2406,11 +2406,13 @@ static int __init ebtables_init(void)
+@@ -2405,11 +2405,13 @@ static int __init ebtables_init(void)
        }
  
        printk(KERN_INFO "Ebtables v2.0 registered\n");
index 09b222d..befd500 100644 (file)
@@ -14,8 +14,6 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  net/ipv6/ip6_tunnel.c          | 276 +++++++++++++++++++++++++++++++++++++++--
  3 files changed, 291 insertions(+), 11 deletions(-)
 
-diff --git a/include/net/ip6_tunnel.h b/include/net/ip6_tunnel.h
-index a5593da..414f5a1 100644
 --- a/include/net/ip6_tunnel.h
 +++ b/include/net/ip6_tunnel.h
 @@ -15,6 +15,18 @@
@@ -45,8 +43,6 @@ index a5593da..414f5a1 100644
  
        __be16                  i_flags;
        __be16                  o_flags;
-diff --git a/include/uapi/linux/if_tunnel.h b/include/uapi/linux/if_tunnel.h
-index aee73d0..c5b25d4 100644
 --- a/include/uapi/linux/if_tunnel.h
 +++ b/include/uapi/linux/if_tunnel.h
 @@ -53,10 +53,23 @@ enum {
@@ -73,8 +69,6 @@ index aee73d0..c5b25d4 100644
  /* SIT-mode i_flags */
  #define       SIT_ISATAP      0x0001
  
-diff --git a/net/ipv6/ip6_tunnel.c b/net/ipv6/ip6_tunnel.c
-index b05b609..c2216b0 100644
 --- a/net/ipv6/ip6_tunnel.c
 +++ b/net/ipv6/ip6_tunnel.c
 @@ -16,6 +16,8 @@
@@ -129,7 +123,7 @@ index b05b609..c2216b0 100644
        }
        t = rcu_dereference(ip6n->tnls_wc[0]);
        if (t && (t->dev->flags & IFF_UP))
-@@ -217,7 +226,7 @@ ip6_tnl_bucket(struct ip6_tnl_net *ip6n, const struct __ip6_tnl_parm *p)
+@@ -217,7 +226,7 @@ ip6_tnl_bucket(struct ip6_tnl_net *ip6n,
  
        if (!ipv6_addr_any(remote) || !ipv6_addr_any(local)) {
                prio = 1;
@@ -138,7 +132,7 @@ index b05b609..c2216b0 100644
        }
        return &ip6n->tnls[prio][h];
  }
-@@ -385,6 +394,12 @@ ip6_tnl_dev_uninit(struct net_device *dev)
+@@ -385,6 +394,12 @@ ip6_tnl_dev_uninit(struct net_device *de
        struct net *net = t->net;
        struct ip6_tnl_net *ip6n = net_generic(net, ip6_tnl_net_id);
  
@@ -260,7 +254,7 @@ index b05b609..c2216b0 100644
  /**
   * ip6_tnl_rcv - decapsulate IPv6 packet and retransmit it locally
   *   @skb: received socket buffer
-@@ -812,6 +928,26 @@ static int ip6_tnl_rcv(struct sk_buff *skb, __u16 protocol,
+@@ -812,6 +929,26 @@ static int ip6_tnl_rcv(struct sk_buff *s
                skb_reset_network_header(skb);
                skb->protocol = htons(protocol);
                memset(skb->cb, 0, sizeof(struct inet6_skb_parm));
@@ -287,7 +281,7 @@ index b05b609..c2216b0 100644
  
                __skb_tunnel_rx(skb, t->dev, t->net);
  
-@@ -1072,6 +1208,7 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, struct net_device *dev)
+@@ -1072,6 +1209,7 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, str
        __u8 dsfield;
        __u32 mtu;
        int err;
@@ -295,7 +289,7 @@ index b05b609..c2216b0 100644
  
        if ((t->parms.proto != IPPROTO_IPIP && t->parms.proto != 0) ||
            !ip6_tnl_xmit_ctl(t))
-@@ -1091,6 +1228,18 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, struct net_device *dev)
+@@ -1091,6 +1229,18 @@ ip4ip6_tnl_xmit(struct sk_buff *skb, str
        if (t->parms.flags & IP6_TNL_F_USE_ORIG_FWMARK)
                fl6.flowi6_mark = skb->mark;
  
@@ -314,7 +308,7 @@ index b05b609..c2216b0 100644
        err = ip6_tnl_xmit2(skb, dev, dsfield, &fl6, encap_limit, &mtu);
        if (err != 0) {
                /* XXX: send ICMP error even if DF is not set. */
-@@ -1259,6 +1408,14 @@ ip6_tnl_change(struct ip6_tnl *t, const struct __ip6_tnl_parm *p)
+@@ -1259,6 +1409,14 @@ ip6_tnl_change(struct ip6_tnl *t, const
        t->parms.flowinfo = p->flowinfo;
        t->parms.link = p->link;
        t->parms.proto = p->proto;
@@ -329,7 +323,7 @@ index b05b609..c2216b0 100644
        ip6_tnl_dst_reset(t);
        ip6_tnl_link_config(t);
        return 0;
-@@ -1289,6 +1446,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_parm *p, const struct ip6_tnl_parm *u)
+@@ -1289,6 +1447,7 @@ ip6_tnl_parm_from_user(struct __ip6_tnl_
        p->flowinfo = u->flowinfo;
        p->link = u->link;
        p->proto = u->proto;
@@ -337,7 +331,7 @@ index b05b609..c2216b0 100644
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1569,6 +1727,15 @@ static int ip6_tnl_validate(struct nlattr *tb[], struct nlattr *data[])
+@@ -1576,6 +1735,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
@@ -353,7 +347,7 @@ index b05b609..c2216b0 100644
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1602,6 +1769,46 @@ static void ip6_tnl_netlink_parms(struct nlattr *data[],
+@@ -1609,6 +1777,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_PROTO])
                parms->proto = nla_get_u8(data[IFLA_IPTUN_PROTO]);
@@ -400,7 +394,7 @@ index b05b609..c2216b0 100644
  }
  
  static int ip6_tnl_newlink(struct net *src_net, struct net_device *dev,
-@@ -1654,6 +1861,12 @@ static void ip6_tnl_dellink(struct net_device *dev, struct list_head *head)
+@@ -1661,6 +1869,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -413,7 +407,7 @@ index b05b609..c2216b0 100644
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -1671,6 +1884,24 @@ static size_t ip6_tnl_get_size(const struct net_device *dev)
+@@ -1678,6 +1892,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(4) +
                /* IFLA_IPTUN_PROTO */
                nla_total_size(1) +
@@ -438,7 +432,7 @@ index b05b609..c2216b0 100644
                0;
  }
  
-@@ -1678,6 +1909,9 @@ static int ip6_tnl_fill_info(struct sk_buff *skb, const struct net_device *dev)
+@@ -1685,6 +1917,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -448,7 +442,7 @@ index b05b609..c2216b0 100644
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put(skb, IFLA_IPTUN_LOCAL, sizeof(struct in6_addr),
-@@ -1688,8 +1922,27 @@ static int ip6_tnl_fill_info(struct sk_buff *skb, const struct net_device *dev)
+@@ -1695,8 +1930,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
@@ -477,7 +471,7 @@ index b05b609..c2216b0 100644
        return 0;
  
  nla_put_failure:
-@@ -1705,6 +1958,7 @@ static const struct nla_policy ip6_tnl_policy[IFLA_IPTUN_MAX + 1] = {
+@@ -1712,6 +1966,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
@@ -485,6 +479,3 @@ index b05b609..c2216b0 100644
  };
  
  static struct rtnl_link_ops ip6_link_ops __read_mostly = {
--- 
-1.9.1
-
index a9ab9e7..6daebe2 100644 (file)
@@ -143,7 +143,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static const struct rt6_info ip6_blk_hole_entry_template = {
        .dst = {
                .__refcnt       = ATOMIC_INIT(1),
-@@ -1594,6 +1611,11 @@ int ip6_route_add(struct fib6_config *cf
+@@ -1595,6 +1612,11 @@ int ip6_route_add(struct fib6_config *cf
                        rt->dst.output = ip6_pkt_prohibit_out;
                        rt->dst.input = ip6_pkt_prohibit;
                        break;
@@ -155,7 +155,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                case RTN_THROW:
                default:
                        rt->dst.error = (cfg->fc_type == RTN_THROW) ? -EAGAIN
-@@ -2173,6 +2195,17 @@ static int ip6_pkt_prohibit_out(struct s
+@@ -2174,6 +2196,17 @@ static int ip6_pkt_prohibit_out(struct s
        return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
@@ -173,7 +173,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  /*
   *    Allocate a dst for local (unicast / anycast) address.
   */
-@@ -2375,7 +2408,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -2376,7 +2409,8 @@ static int rtm_to_fib6_config(struct sk_
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
            rtm->rtm_type == RTN_PROHIBIT ||
@@ -183,7 +183,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -2577,6 +2611,9 @@ static int rt6_fill_node(struct net *net
+@@ -2578,6 +2612,9 @@ static int rt6_fill_node(struct net *net
                case -EACCES:
                        rtm->rtm_type = RTN_PROHIBIT;
                        break;
@@ -193,7 +193,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                case -EAGAIN:
                        rtm->rtm_type = RTN_THROW;
                        break;
-@@ -2827,6 +2864,8 @@ static int ip6_route_dev_notify(struct n
+@@ -2828,6 +2865,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -3043,6 +3082,17 @@ static int __net_init ip6_route_net_init
+@@ -3044,6 +3083,17 @@ static int __net_init ip6_route_net_init
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
@@ -220,7 +220,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
  
        net->ipv6.sysctl.flush_delay = 0;
-@@ -3061,6 +3111,8 @@ out:
+@@ -3062,6 +3112,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -229,7 +229,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -3078,6 +3130,7 @@ static void __net_exit ip6_route_net_exi
+@@ -3079,6 +3131,7 @@ static void __net_exit ip6_route_net_exi
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
        kfree(net->ipv6.ip6_blk_hole_entry);
@@ -237,7 +237,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
  }
-@@ -3174,6 +3227,9 @@ int __init ip6_route_init(void)
+@@ -3175,6 +3228,9 @@ int __init ip6_route_init(void)
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
index 3421e4d..e472a96 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1244,6 +1244,11 @@ struct net_device {
+@@ -1245,6 +1245,11 @@ struct net_device {
        const struct ethtool_ops *ethtool_ops;
        const struct forwarding_accel_ops *fwd_ops;
  
@@ -12,7 +12,7 @@
        /* Hardware header description */
        const struct header_ops *header_ops;
  
-@@ -1312,6 +1317,9 @@ struct net_device {
+@@ -1313,6 +1318,9 @@ struct net_device {
        void                    *ax25_ptr;      /* AX.25 specific data */
        struct wireless_dev     *ieee80211_ptr; /* IEEE 802.11 specific data,
                                                   assign before registering */
index 06fcdb0..8154763 100644 (file)
@@ -68,7 +68,7 @@
  
 --- a/fs/open.c
 +++ b/fs/open.c
-@@ -665,9 +665,12 @@ int open_check_o_direct(struct file *f)
+@@ -654,9 +654,12 @@ int open_check_o_direct(struct file *f)
  {
        /* NB: we're sure to have correct a_ops only after f_op->open */
        if (f->f_flags & O_DIRECT) {
index e995dae..22e3cba 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.4
+LINUX_VERSION:=3.14.5
 
 KERNELNAME:=bzImage