kernel: update linux 3.0 to 3.0.18
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jan 2012 09:43:53 +0000 (09:43 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 31 Jan 2012 09:43:53 +0000 (09:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29965 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/patches-3.0/0045-ssb-fix-cardbus-in-hostmode.patch
target/linux/brcm63xx/Makefile
target/linux/malta/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/realview/Makefile
target/linux/uml/Makefile

index e66653f..85bfe81 100644 (file)
@@ -29,8 +29,8 @@ endif
 ifeq ($(LINUX_VERSION),2.6.39.4)
   LINUX_KERNEL_MD5SUM:=a17c748c2070168f1e784e9605ca043d
 endif
-ifeq ($(LINUX_VERSION),3.0.17)
-  LINUX_KERNEL_MD5SUM:=fcdd6a945445336e4cd28b2d195f1fea
+ifeq ($(LINUX_VERSION),3.0.18)
+  LINUX_KERNEL_MD5SUM:=67252770d7009eabe8bac7c26e074f9d
 endif
 ifeq ($(LINUX_VERSION),3.1.9)
   LINUX_KERNEL_MD5SUM:=4e387a49cde20805955c905bc8c311e0
index 8f3362a..0212ee6 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index 4837fe7..0a329c0 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 
 --- a/drivers/ssb/driver_pcicore.c
 +++ b/drivers/ssb/driver_pcicore.c
-@@ -75,7 +75,7 @@ static u32 get_cfgspace_addr(struct ssb_
+@@ -74,7 +74,7 @@ static u32 get_cfgspace_addr(struct ssb_
        u32 tmp;
  
        /* We do only have one cardbus device behind the bridge. */
@@ -19,4 +19,4 @@ Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
 +      if (pc->cardbusmode && (dev > 1))
                goto out;
  
-       /* Type 0 transaction */
+       if (bus == 0) {
index 77e0a39..88c4561 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index 50e0731..6557a85 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=le be
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index f1da2a6..ed899a1 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=generic harddisk
 CFLAGS=-Os -pipe -march=armv5te -mtune=xscale -fno-caller-saves
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index abbefba..2efb13a 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 3d5789e..ed57187 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 9b980b0..b720079 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=fpu ramdisk
 CFLAGS:=-Os -pipe -march=armv6k -mtune=mpcore -mfloat-abi=softfp -mfpu=vfp -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a6c9db..97bb311 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.0.17
+LINUX_VERSION:=3.0.18
 
 include $(INCLUDE_DIR)/target.mk