lantiq: several a803 related fixes
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Aug 2013 10:42:00 +0000 (10:42 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Aug 2013 10:42:00 +0000 (10:42 +0000)
based on work from Matti Laasko that he posted in the wiki

Signed-off-by: John Crispin <blogic@openwrt.or
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37704 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/lantiq/base-files/etc/hotplug.d/firmware/10-rt2x00-eeprom
target/linux/lantiq/base-files/etc/uci-defaults/02_network
target/linux/lantiq/dts/ARV752DPW22.dts
target/linux/lantiq/xway/profiles/arv.mk

index 3f92828..7ec8d6f 100644 (file)
@@ -29,7 +29,7 @@ case "$FIRMWARE" in
 "RT2860.eeprom" )
        local board=$(lantiq_board_id)
        case $board in
-       ARV7525PW|ARV752DPW)
+       ARV7525PW|ARV752DPW|ARV752DPW22)
                rt2x00_eeprom_extract "board_config" 1040 512
                ;;
        *)
index 1d3a117..f5401c3 100755 (executable)
@@ -58,7 +58,7 @@ ACMP252|GIGASX76X)
        ;;
 
 # ar8316
-ARV4519PW|ARV7518PW)
+ARV4519PW|ARV7518PW|ARV752DPW22)
        ucidef_set_interface_lan "eth0.1"
        ucidef_add_switch "switch0" "1" "1"
        ucidef_add_switch_vlan "switch0" "1" "0t 2 3 4 5"
index a9b1ae0..983386d 100644 (file)
 
                                partition@0 {
                                        label = "uboot";
-                                       reg = <0x00000 0x10000>;
+                                       reg = <0x00000 0x30000>;
                                        read-only;
                                };
 
                                partition@10000 {
                                        label = "uboot_env";
-                                       reg = <0x10000 0x10000>;
+                                       reg = <0x30000 0x10000>;
                                        read-only;
                                };
 
                                partition@20000 {
                                        label = "linux";
-                                       reg = <0x20000 0x7d0000>;
+                                       reg = <0x40000 0x7b0000>;
                                };
 
                                partition@7f0000 {
                                        lantiq,output = <0>;
                                };
                                pci_in {
-                                       lantiq,groups = "req1", "req2";
+                                       lantiq,groups = "req1";
                                        lantiq,function = "pci";
-                                       lantiq,open-drain = <1>;
                                        lantiq,pull = <2>;
                                        lantiq,output = <0>;
                                };
                                pci_out {
                                        lantiq,groups = "gnt1";
                                        lantiq,function = "pci";
+                                       lantiq,open-drain = <1>;
                                        lantiq,output = <1>;
                                };
                                pci_rst {
                                        lantiq,pins = "io21";
-                                       lantiq,pull = <2>;
+                                       lantiq,open-drain = <1>;
                                        lantiq,output = <1>;
                                };
                                leds {
                                        lantiq,pins = "io3", "io5", "io6", "io8";
+                                       lantiq,open-drain = <1>;
                                        lantiq,output = <1>;
                                };
+                               buttons {
+                                       lantiq,pins = "io11", "io12", "io13", "io28";
+                                       lantiq,pull = <2>;
+                                       lantiq,output = <0>;
+                               };
                        };
                };
 
                };
 
                etop@E180000 {
-                       phy-mode = "rmii";
+                       phy-mode = "mii";
                };
 
                pci@E105400 {
index 797969a..4528741 100644 (file)
@@ -116,7 +116,7 @@ $(eval $(call Profile,ARV752DPW))
 
 define Profile/ARV752DPW22
   NAME:=Easybox 803 - ARV752DPW22
-  PACKAGES:=kmod-usb2 kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
+  PACKAGES:=kmod-usb2-pci kmod-usb-uhci kmod-ltq-hcd-danube kmod-ledtrig-usbdev \
        kmod-ltq-adsl-danube-mei kmod-ltq-adsl-danube \
        kmod-ltq-adsl-danube-fw-b kmod-ltq-atm-danube \
        ltq-adsl-app ppp-mod-pppoa \