Add support for Sagem F@ST2404 (#4332)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Dec 2008 16:13:41 +0000 (16:13 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 10 Dec 2008 16:13:41 +0000 (16:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@13583 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
target/linux/brcm63xx/image/Makefile

index 599ec5d..d94686d 100644 (file)
@@ -115,6 +115,31 @@ static struct board_info __initdata board_96348gw = {
 
        .has_ohci0 = 1,
 };
+
+static struct board_info __initdata board_FAST2404 = {
+        .name                           = "F@ST2404",
+        .expected_cpu_id                = 0x6348,
+
+        .has_enet0                      = 1,
+        .has_enet1                      = 1,
+        .has_pci                        = 1,
+
+        .enet0 = {
+                .has_phy                = 1,
+                .use_internal_phy       = 1,
+        },
+
+        .enet1 = {
+                .force_speed_100        = 1,
+                .force_duplex_full      = 1,
+        },
+
+
+        .has_ohci0 = 1,
+        .has_pccard = 1,
+        .has_ehci0 = 1,
+};
+
 #endif
 
 /*
@@ -179,6 +204,7 @@ static const struct board_info __initdata *bcm963xx_boards[] = {
        &board_96348gw,
        &board_96348gw_10,
        &board_96348gw_11,
+       &board_FAST2404,
 #endif
 
 #ifdef CONFIG_BCM63XX_CPU_6358
index ac22fee..64fde3c 100644 (file)
@@ -80,6 +80,8 @@ define Image/Build
        $(call Image/Build/CFE,$(1),96348GW-11,6348)
        # DG834G
        $(call Image/Build/CFE,$(1),96348GW-10,6348)
+       # Sagem F@ST2404
+       $(call Image/Build/CFE,$(1),F@ST2404,6348)
 endef
 
 $(eval $(call BuildImage))