kernel: add mii library kernel module package
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Oct 2013 01:47:32 +0000 (01:47 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 25 Oct 2013 01:47:32 +0000 (01:47 +0000)
This package is required for network drivers such as pcnet32

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38530 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/netdevices.mk

index 9c808e1..6cac27a 100644 (file)
@@ -95,6 +95,20 @@ endef
 
 $(eval $(call KernelPackage,libphy))
 
+define KernelPackage/mii
+  SUBMENU:=$(NETWORK_DEVICES_MENU)
+  TITLE:=MII library
+  KCONFIG:=CONFIG_MII
+  FILES:=$(LINUX_DIR)/drivers/net/mii.ko
+  AUTOLOAD:=$(call AutoLoad,15,mii,1)
+endef
+
+define KernelPackage/mii/description
+  MII library
+endef
+
+$(eval $(call KernelPackage,mii))
+
 
 define KernelPackage/et131x
   SUBMENU:=$(NETWORK_DEVICES_MENU)