upgrade & standardize kernel versions
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Feb 2008 10:50:40 +0000 (10:50 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Feb 2008 10:50:40 +0000 (10:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10443 3c298f89-4303-0410-b956-a3cf2f4a3e73

23 files changed:
include/kernel-version.mk
target/linux/adm5120/Makefile
target/linux/amazon/Makefile
target/linux/ar7/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/avr32/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/ifxmips/Makefile
target/linux/iop32x/Makefile
target/linux/ixp4xx/Makefile
target/linux/magicbox/Makefile
target/linux/olpc/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/ps3/Makefile
target/linux/pxa/Makefile
target/linux/rb532/Makefile
target/linux/rdc/Makefile
target/linux/sibyte/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile

index 5ecd305..b3aaf00 100644 (file)
@@ -13,23 +13,17 @@ endif
 ifeq ($(LINUX_VERSION),2.4.35.4)
   LINUX_KERNEL_MD5SUM:=34066faff3d8c042df1c7600b08b8070
 endif
-ifeq ($(LINUX_VERSION),2.6.22.4)
-  LINUX_KERNEL_MD5SUM:=6cf83acf21e65dcea4a5170c0bbc7125
+ifeq ($(LINUX_VERSION),2.6.21.7)
+  LINUX_KERNEL_MD5SUM:=bc15fad1487336d5dcb0945cd039d8ed
 endif
-ifeq ($(LINUX_VERSION),2.6.21.5)
-  LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
+ifeq ($(LINUX_VERSION),2.6.22.18)
+  LINUX_KERNEL_MD5SUM:=bd375d5885bf114c74a2216d52d86e34
 endif
-ifeq ($(LINUX_VERSION),2.6.23)
-  LINUX_KERNEL_MD5SUM:=2cc2fd4d521dc5d7cfce0d8a9d1b3472
+ifeq ($(LINUX_VERSION),2.6.23.16)
+  LINUX_KERNEL_MD5SUM:=2637a7f1d4450bc5e27422f307fc6529
 endif
-ifeq ($(LINUX_VERSION),2.6.23.1)
-  LINUX_KERNEL_MD5SUM:=518d57e08fdacd88907166a3bfe383b7
-endif
-ifeq ($(LINUX_VERSION),2.6.23.14)
-  LINUX_KERNEL_MD5SUM:=63a6a28ad2480edcffbc09c008b0939d
-endif
-ifeq ($(LINUX_VERSION),2.6.24)
-  LINUX_KERNEL_MD5SUM:=3f23ad4b69d0a552042d1ed0f4399857
+ifeq ($(LINUX_VERSION),2.6.24.2)
+  LINUX_KERNEL_MD5SUM:=dd573a2fae55624ed92fa49c17583964
 endif
 
 # disable the md5sum check for unknown kernel versions
index c7c6670..a397f2a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon ADM5120
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 SUBTARGETS:=router_le router_be
 INITRAMFS_EXTRA_FILES:=
 
index b8491c2..576f850 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
 
 include $(INCLUDE_DIR)/target.mk
 
index abe32eb..fc83f9a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index dfa3bfb..fb04344 100644 (file)
@@ -11,8 +11,7 @@ BOARD:=at91
 BOARDNAME:=AT91
 FEATURES:=squashfs usb
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.22.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 93f026b..6cab959 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.23.1
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 77b8c96..4b49284 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=avr32
 BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 36f7ef7..50b60f1 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.23.1
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-switch kmod-diag
index 0e08984..c465c86 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.22.18
 
 include $(INCLUDE_DIR)/target.mk
 
index 1818e6b..e63ad08 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=ifxmips
 BOARDNAME:=Infineon Mips
 FEATURES:=squashfs jffs2 broken
-LINUX_VERSION:=2.6.23
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 8267625..ccecf20 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=iop32x
 BOARDNAME:=Intel XScale IOP32x
 FEATURES:=squashfs jffs2
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 5ef4c8c..ec931a0 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel XScale IXP4xx
 FEATURES:=squashfs
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index fae0ebf..c03093e 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs pci
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
index 4ab3375..8bf4cd8 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=olpc
 BOARDNAME:=olpc
 FEATURES:=squashfs ext2
 
-LINUX_VERSION:=2.6.23
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
index cd64ea3..b081849 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc40x
 BOARDNAME:=AMCC Kilauea
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 9b4342c..7e70612 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=ppc44x
 BOARDNAME:=AMCC Taishan
 FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk
index 3499d02..653ba80 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ps3
 BOARDNAME:=Sony PlayStation 3
-LINUX_VERSION:=2.6.23
+LINUX_VERSION:=2.6.23.16
 KERNEL_CC:=
 
 include $(INCLUDE_DIR)/target.mk
index b5985ea..7bf4c38 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=pxa
 BOARDNAME:=PXA
 FEATURES:=jffs2 broken
 
-LINUX_VERSION:=2.6.21.5
+LINUX_VERSION:=2.6.21.7
 
 include $(INCLUDE_DIR)/target.mk
 
index 69e9eab..9e4fcca 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2 pci tgz
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a61ae3..1b70c18 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rdc
 BOARDNAME:=RDC321x x86
 FEATURES:=squashfs jffs2 pci
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 74c15cb..dfc8632 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sibyte
 BOARDNAME:=Broadcom/SiByte SB-1
 FEATURES:=broken
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 11c8b76..ebcfbbc 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=broken ext2
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
-LINUX_VERSION:=2.6.24
+LINUX_VERSION:=2.6.24.2
 
 include $(INCLUDE_DIR)/target.mk
 
index 6cb5c3d..afff2c6 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
 SUBTARGETS=generic mediacenter
 
-LINUX_VERSION:=2.6.23.14
+LINUX_VERSION:=2.6.23.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci