do target dependent optimizations
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Apr 2008 13:24:30 +0000 (13:24 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 14 Apr 2008 13:24:30 +0000 (13:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10834 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/Makefile
toolchain/Config.in

index 918424d..f2fdac7 100644 (file)
@@ -39,10 +39,10 @@ endif
 ifeq ($(ARCH),i686)
   HAL_TARGET:=i386-elf
 endif
-ifeq ($(ARCH),armeb)
+ifeq ($(BOARD),ixp4xx)
   HAL_TARGET:=xscale-be-elf
 endif
-ifeq ($(ARCH),arm)
+ifeq ($(BOARD),iop32x)
   HAL_TARGET:=xscale-le-elf
 endif
 ifeq ($(ARCH),powerpc)
index c4f6e14..1d7f1ab 100644 (file)
@@ -84,7 +84,7 @@ config TARGET_OPTIMIZATION
        default "-O2 -pipe -march=i486 -funit-at-a-time" if TARGET_x86
        default "-Os -pipe -march=i486 -funit-at-a-time" if TARGET_rdc
        default "-Os -pipe -mips32 -mtune=mips32 -funit-at-a-time" if mipsel || mips
-       default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if armeb || arm
+       default "-Os -pipe -march=armv5te -mtune=xscale -funit-at-a-time" if TARGET_ixp4xx || TARGET_iop32x
        default "-Os -pipe -funit-at-a-time"
        help
          Optimizations to use when building for the target host.