[include] autotools.mk: cope with Debian version strings in libtool
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 21:50:50 +0000 (21:50 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 Jun 2012 21:50:50 +0000 (21:50 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32207 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/autotools.mk

index c5ba748..8796598 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -51,9 +51,9 @@ endef
 
 # 1: build dir
 define patch_libtool
-       (cd $(1); \
+       @(cd $(1); \
                for lt in $$$$($$(STAGING_DIR_HOST)/bin/find . -name ltmain.sh); do \
-                       lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION=\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
+                       lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION="\?\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
                        case "$$$$lt_version" in \
                                1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \
                                        (cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \