build: disable initramfs build within image builder
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 May 2015 09:17:39 +0000 (09:17 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 11 May 2015 09:17:39 +0000 (09:17 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45673 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 1b7fd24..b8be838 100644 (file)
@@ -362,6 +362,7 @@ define Device/Check
   _COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
 endef
 
+ifndef IB
 define Device/Build/initramfs
   $$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
 
@@ -373,6 +374,7 @@ define Device/Build/initramfs
        @rm -f $$@
        $$(call concat_cmd,$$(KERNEL_INITRAMFS))
 endef
+endif
 
 define Device/Build/check_size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \