kernel: adjust orion/kirkwood packages to also build for mvebu target
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Jan 2013 22:20:21 +0000 (22:20 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Jan 2013 22:20:21 +0000 (22:20 +0000)
Armada XP/370 boards share these hardware blocks with Orion and Kirkwood
SoCs.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35059 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/crypto.mk
package/kernel/modules/i2c.mk
package/kernel/modules/other.mk

index 02e3f68..221b5a0 100644 (file)
@@ -486,7 +486,7 @@ $(eval $(call KernelPackage,crypto-xts))
 
 define KernelPackage/crypto-mv-cesa
   TITLE:=Marvell crypto engine
-  DEPENDS:=+kmod-crypto-manager +kmod-crypto-aes @TARGET_kirkwood||TARGET_orion
+  DEPENDS:=+kmod-crypto-manager +kmod-crypto-aes @TARGET_kirkwood||TARGET_orion||TARGET_mvebu
   KCONFIG:=CONFIG_CRYPTO_DEV_MV_CESA
   FILES:=$(LINUX_DIR)/drivers/crypto/mv_cesa.ko
   AUTOLOAD:=$(call AutoLoad,09,mv_cesa)
index 0a49820..2ee73bf 100644 (file)
@@ -154,11 +154,11 @@ I2C_MV64XXX_MODULES:=\
 define KernelPackage/i2c-mv64xxx
   $(call i2c_defaults,$(I2C_MV64XXX_MODULES),59)
   TITLE:=Orion Platform I2C interface support
-  DEPENDS:=@TARGET_kirkwood||TARGET_orion +kmod-i2c-core
+  DEPENDS:=@TARGET_kirkwood||TARGET_orion||TARGET_mvebu +kmod-i2c-core
 endef
 
 define KernelPackage/i2c-mv64xxx/description
- Kernel module for I2C interface on the Kirkwood and Orion
+ Kernel module for I2C interface on the Kirkwood, Orion and Armada XP/370
  family processors.
 endef
 
index 5d3e00a..d4983a3 100644 (file)
@@ -479,14 +479,14 @@ $(eval $(call KernelPackage,wdt-omap))
 define KernelPackage/wdt-orion
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Marvell Orion Watchdog timer
-  DEPENDS:=@TARGET_orion||@TARGET_kirkwood
+  DEPENDS:=@TARGET_orion||TARGET_kirkwood||TARGET_mvebu
   KCONFIG:=CONFIG_ORION_WATCHDOG
   FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/orion_wdt.ko
   AUTOLOAD:=$(call AutoLoad,50,orion_wdt)
 endef
 
 define KernelPackage/wdt-orion/description
-  Kernel module for Marvell orion watchdog timer.
+  Kernel module for Marvell Orion, Kirkwood and Armada XP/370 watchdog timer.
 endef
 
 $(eval $(call KernelPackage,wdt-orion))