[toolchain] gcc: update gcc-4.6-linaro to 4.6-2012.10
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Oct 2012 19:19:38 +0000 (19:19 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 13 Oct 2012 19:19:38 +0000 (19:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33758 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/gcc/common.mk
toolchain/gcc/patches/4.6-linaro/000-gcc-bug-54369.patch [deleted file]
toolchain/gcc/patches/4.6-linaro/002-siginfo_t.patch [deleted file]

index 53e4635..4970ccd 100644 (file)
@@ -44,10 +44,10 @@ ifeq ($(findstring linaro, $(CONFIG_GCC_VERSION)),linaro)
       PKG_MD5SUM:=e05be9ea8eca2ad4c859d35dbab568e7
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.6-linaro")
-      PKG_REV:=4.6-2012.02
-      PKG_VERSION:=4.6.3
+      PKG_REV:=4.6-2012.10
+      PKG_VERSION:=4.6.4
       PKG_VERSION_MAJOR:=4.6
-      PKG_MD5SUM:=2b7887846f8e5ac1ca58fe4dfaabf5a6
+      PKG_MD5SUM:=acd304caf055ccaaca4e3ef61da11e7d
     endif
     ifeq ($(CONFIG_GCC_VERSION),"4.7-linaro")
       PKG_REV:=4.7-2012.04
diff --git a/toolchain/gcc/patches/4.6-linaro/000-gcc-bug-54369.patch b/toolchain/gcc/patches/4.6-linaro/000-gcc-bug-54369.patch
deleted file mode 100644 (file)
index b91f0eb..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-Author: ebotcazou
-Date: Sun Sep  2 10:37:49 2012
-New Revision: 190860
-
-URL: http://gcc.gnu.org/viewcvs?root=gcc&view=rev&rev=190860
-Log:
-    PR rtl-optimization/54369
-    * config/mips/mips.c (mips_reorg): Invoke cleanup_barriers before
-    calling dbr_schedule.
-    * config/sparc/sparc.c (sparc_reorg): Likewise.
-
-Modified:
-    branches/gcc-4_6-branch/gcc/ChangeLog
-    branches/gcc-4_6-branch/gcc/config/mips/mips.c
-    branches/gcc-4_6-branch/gcc/config/sparc/sparc.c
----
---- gcc-4_6-branch/gcc/config/mips/mips.c      2012/09/02 10:36:54     190859
-+++ gcc-4_6-branch/gcc/config/mips/mips.c      2012/09/02 10:37:49     190860
-@@ -15083,7 +15083,10 @@
-     }
-   if (optimize > 0 && flag_delayed_branch)
--    dbr_schedule (get_insns ());
-+    {
-+      cleanup_barriers ();
-+      dbr_schedule (get_insns ());
-+    }
-   mips_reorg_process_insns ();
-   if (!TARGET_MIPS16
-       && TARGET_EXPLICIT_RELOCS
---- gcc-4_6-branch/gcc/config/sparc/sparc.c    2012/09/02 10:36:54     190859
-+++ gcc-4_6-branch/gcc/config/sparc/sparc.c    2012/09/02 10:37:49     190860
-@@ -9456,7 +9456,10 @@
-   /* We need to have the (essentially) final form of the insn stream in order
-      to properly detect the various hazards.  Run delay slot scheduling.  */
-   if (optimize > 0 && flag_delayed_branch)
--    dbr_schedule (get_insns ());
-+    {
-+      cleanup_barriers ();
-+      dbr_schedule (get_insns ());
-+    }
-   /* Now look for specific patterns in the insn stream.  */
-   for (insn = get_insns (); insn; insn = next)
-
diff --git a/toolchain/gcc/patches/4.6-linaro/002-siginfo_t.patch b/toolchain/gcc/patches/4.6-linaro/002-siginfo_t.patch
deleted file mode 100644 (file)
index a19b7f2..0000000
+++ /dev/null
@@ -1,157 +0,0 @@
-There is one usage in boehm-gc/os_dep.c, but it is only used if
-SUNOS5SIGS is defined, which it is only if one of SUNOS5, DRSNX, HPUX, or
-FREEBSD is defined, which are all not using Linux-based glibc ports.
-
-Likewise, gcc/ada/init.c has a struct __siginfo occurence, but only for
-__FreeBSD__.
-
-config/rs6000/linux-unwind.h uses ``char siginfo[128]'', and
-config/s390/linux-unwind.h also uses a constant.
-
-I tested the following patch for sh-linux-gnu.  This only covers one
-configuration, but the change is pretty mechanic anyway and every place
-that used to refer to struct siginfo already must have had <signal.h> in
-its include path, which is the same file that declares siginfo_t.
-
-OK to commit?  This should probably also go into any active release
-branches, to keep them buildable once this glibc change ripples through?
-
-gcc/
-        * config/alpha/linux-unwind.h (alpha_fallback_frame_state): Use
-        siginfo_t instead of struct siginfo.
-        * config/bfin/linux-unwind.h (bfin_fallback_frame_state): Likewise.
-        * config/i386/linux-unwind.h (x86_fallback_frame_state): Likewise.
-        * config/ia64/linux-unwind.h (ia64_fallback_frame_state)
-        (ia64_handle_unwabi): Likewise.
-        * config/mips/linux-unwind.h (mips_fallback_frame_state): Likewise.
-        * config/pa/linux-unwind.h (pa32_fallback_frame_state): Likewise.
-        * config/sh/linux-unwind.h (shmedia_fallback_frame_state)
-        (sh_fallback_frame_state): Likewise.
-        * config/tilepro/linux-unwind.h (tile_fallback_frame_state): Likewise.
-        * config/xtensa/linux-unwind.h (xtensa_fallback_frame_state): Likewise.
-
----
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/alpha/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/alpha/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/alpha/linux-unwind.h     2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/alpha/linux-unwind.h 2012-09-13 10:25:52.919072751 +0200
-@@ -49,7 +49,7 @@
-   else if (pc[1] == 0x201f015f)               /* lda $0,NR_rt_sigreturn */
-     {
-       struct rt_sigframe {
--      struct siginfo info;
-+      siginfo_t info;
-       struct ucontext uc;
-       } *rt_ = context->cfa;
-       sc = &rt_->uc.uc_mcontext;
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/bfin/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/bfin/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/bfin/linux-unwind.h      2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/bfin/linux-unwind.h  2012-09-13 10:26:14.819073313 +0200
-@@ -48,10 +48,10 @@
-     {
-       struct rt_sigframe {
-       int sig;
--      struct siginfo *pinfo;
-+      siginfo_t *pinfo;
-       void *puc;
-       char retcode[8];
--      struct siginfo info;
-+      siginfo_t info;
-       struct ucontext uc;
-       } *rt_ = context->cfa;
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/i386/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/i386/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/i386/linux-unwind.h      2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/i386/linux-unwind.h  2012-09-13 10:26:41.891074005 +0200
-@@ -133,9 +133,9 @@
-     {
-       struct rt_sigframe {
-       int sig;
--      struct siginfo *pinfo;
-+      siginfo_t *pinfo;
-       void *puc;
--      struct siginfo info;
-+      siginfo_t info;
-       struct ucontext uc;
-       } *rt_ = context->cfa;
-       /* The void * cast is necessary to avoid an aliasing warning.
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/ia64/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/ia64/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/ia64/linux-unwind.h      2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/ia64/linux-unwind.h  2012-09-13 10:26:59.251074450 +0200
-@@ -47,7 +47,7 @@
-       struct sigframe {
-       char scratch[16];
-       unsigned long sig_number;
--      struct siginfo *info;
-+      siginfo_t *info;
-       struct sigcontext *sc;
-       } *frame_ = (struct sigframe *)context->psp;
-       struct sigcontext *sc = frame_->sc;
-@@ -137,7 +137,7 @@
-       struct sigframe {
-       char scratch[16];
-       unsigned long sig_number;
--      struct siginfo *info;
-+      siginfo_t *info;
-       struct sigcontext *sc;
-       } *frame = (struct sigframe *)context->psp;
-       struct sigcontext *sc = frame->sc;
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/mips/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/mips/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/mips/linux-unwind.h      2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/mips/linux-unwind.h  2012-09-13 10:27:17.947074929 +0200
-@@ -75,7 +75,7 @@
-       struct rt_sigframe {
-       u_int32_t ass[4];  /* Argument save space for o32.  */
-       u_int32_t trampoline[2];
--      struct siginfo info;
-+      siginfo_t info;
-       _sig_ucontext_t uc;
-       } *rt_ = context->cfa;
-       sc = &rt_->uc.uc_mcontext;
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/pa/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/pa/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/pa/linux-unwind.h        2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/pa/linux-unwind.h    2012-09-13 10:27:27.491075173 +0200
-@@ -63,7 +63,7 @@
-   int i;
-   struct sigcontext *sc;
-   struct rt_sigframe {
--    struct siginfo info;
-+    siginfo_t info;
-     struct ucontext uc;
-   } *frame;
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/sh/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/sh/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/sh/linux-unwind.h        2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/sh/linux-unwind.h    2012-09-13 10:27:58.551075969 +0200
-@@ -80,9 +80,9 @@
-          && (*(unsigned long *) (pc+11)  == 0x6ff0fff0))
-     {
-       struct rt_sigframe {
--      struct siginfo *pinfo;
-+      siginfo_t *pinfo;
-       void *puc;
--      struct siginfo info;
-+      siginfo_t info;
-       struct ucontext uc;
-       } *rt_ = context->cfa;
-       /* The void * cast is necessary to avoid an aliasing warning.
-@@ -179,7 +179,7 @@
-               && (*(unsigned short *) (pc+14)  == 0x00ad))))
-     {
-       struct rt_sigframe {
--      struct siginfo info;
-+      siginfo_t info;
-       struct ucontext uc;
-       } *rt_ = context->cfa;
-       /* The void * cast is necessary to avoid an aliasing warning.
-diff -urN gcc-linaro-4.6-2012.02/gcc/config/xtensa/linux-unwind.h gcc-linaro-4.6-2012.02.new/gcc/config/xtensa/linux-unwind.h
---- gcc-linaro-4.6-2012.02/gcc/config/xtensa/linux-unwind.h    2012-02-07 11:33:31.000000000 +0100
-+++ gcc-linaro-4.6-2012.02.new/gcc/config/xtensa/linux-unwind.h        2012-09-13 10:28:13.827076359 +0200
-@@ -62,7 +62,7 @@
-   struct sigcontext *sc;
-   struct rt_sigframe {
--    struct siginfo info;
-+    siginfo_t info;
-     struct ucontext uc;
-   } *rt_;