rename toolchain/libmissing to libnotimpl (fix dnsiff build)
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 7 Oct 2005 17:05:47 +0000 (17:05 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 7 Oct 2005 17:05:47 +0000 (17:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2065 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libvorbis/Makefile
toolchain/libmissing/Makefile [deleted file]
toolchain/libmissing/files/math.c [deleted file]
toolchain/libnotimpl/Makefile [new file with mode: 0644]
toolchain/libnotimpl/files/math.c [new file with mode: 0644]

index 1777ed8..1054a7f 100644 (file)
@@ -18,7 +18,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,LIBVORBIS,libvorbis,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-# NOTE: check ./toolchain/libmissing
+# NOTE: check ./toolchain/libnotimpl
 # it implements those functions missing from the version of uClibc we're currently using
 # for libvorbis, they are cosf/sinf
 
@@ -28,7 +28,7 @@ $(PKG_BUILD_DIR)/.configured:
                CFLAGS="$(strip $(TARGET_CFLAGS))" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               LIBS="-lm -logg -lmissing" \
+               LIBS="-lm -logg -lnotimpl" \
                PKG_CONFIG_PATH="$(STAGING_DIR)/usr/lib/pkgconfig" \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
diff --git a/toolchain/libmissing/Makefile b/toolchain/libmissing/Makefile
deleted file mode 100644 (file)
index bd3749d..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-include $(TOPDIR)/rules.mk
-
-LIBMISSING_DIR:=$(TOOL_BUILD_DIR)/libmissing
-
-LIBMISSING_SRCS+=./files/math.c
-LIBMISSING_OBJS:=$(patsubst ./files/%.c,$(LIBMISSING_DIR)/%.o,$(LIBMISSING_SRCS))
-
-$(LIBMISSING_DIR)/.prepared:
-       mkdir -p $(LIBMISSING_DIR)
-       touch $@
-
-$(LIBMISSING_OBJS): $(LIBMISSING_DIR)/%.o : ./files/%.c
-       $(TARGET_CC) $(TARGET_CFLAGS) -c $< -o $@
-
-$(LIBMISSING_DIR)/libmissing.a: $(LIBMISSING_OBJS)
-       $(TARGET_CROSS)ar rc $(LIBMISSING_DIR)/libmissing.a $(LIBMISSING_OBJS)
-
-$(STAGING_DIR)/usr/lib/libmissing.a: $(LIBMISSING_DIR)/libmissing.a
-       mkdir -p $(STAGING_DIR)/usr/lib
-       cp -fpR $< $@
-       touch -c $@
-
-source:
-prepare: $(LIBMISSING_DIR)/.prepared
-compile: $(LIBMISSING_DIR)/libmissing.a
-install: $(STAGING_DIR)/usr/lib/libmissing.a
-clean: 
-       rm -rf \
-               $(STAGING_DIR)/usr/lib/libmissing.a \
-               $(LIBMISSING_DIR) \
diff --git a/toolchain/libmissing/files/math.c b/toolchain/libmissing/files/math.c
deleted file mode 100644 (file)
index cc8a661..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-/* vi: set sw=4 ts=4: */
-
-/* cosf for uClibc
- *
- * wrapper for cos(x)
- */
-
-#include "math.h"
-
-#ifdef __STDC__
-       float cosf(float x)             /* wrapper cos */
-#else
-       float cosf(x)                   /* wrapper cos */
-       float x;
-#endif
-{
-       return (float) cos( (double)x );
-}
-
-/* sinf for uClibc
- *
- * wrapper for sin(x)
- */
-
-#include "math.h"
-
-#ifdef __STDC__
-       float sinf(float x)             /* wrapper sin */
-#else
-       float sinf(x)                   /* wrapper sin */
-       float x;
-#endif
-{
-       return (float) sin( (double)x );
-}
diff --git a/toolchain/libnotimpl/Makefile b/toolchain/libnotimpl/Makefile
new file mode 100644 (file)
index 0000000..9ae2bf2
--- /dev/null
@@ -0,0 +1,30 @@
+include $(TOPDIR)/rules.mk
+
+LIBNOTIMPL_DIR:=$(TOOL_BUILD_DIR)/libnotimpl
+
+LIBNOTIMPL_SRCS+=./files/math.c
+LIBNOTIMPL_OBJS:=$(patsubst ./files/%.c,$(LIBNOTIMPL_DIR)/%.o,$(LIBNOTIMPL_SRCS))
+
+$(LIBNOTIMPL_DIR)/.prepared:
+       mkdir -p $(LIBNOTIMPL_DIR)
+       touch $@
+
+$(LIBNOTIMPL_OBJS): $(LIBNOTIMPL_DIR)/%.o : ./files/%.c
+       $(TARGET_CC) $(TARGET_CFLAGS) -c $< -o $@
+
+$(LIBNOTIMPL_DIR)/libnotimpl.a: $(LIBNOTIMPL_OBJS)
+       $(TARGET_CROSS)ar rc $(LIBNOTIMPL_DIR)/libnotimpl.a $(LIBNOTIMPL_OBJS)
+
+$(STAGING_DIR)/usr/lib/libnotimpl.a: $(LIBNOTIMPL_DIR)/libnotimpl.a
+       mkdir -p $(STAGING_DIR)/usr/lib
+       cp -fpR $< $@
+       touch -c $@
+
+source:
+prepare: $(LIBNOTIMPL_DIR)/.prepared
+compile: $(LIBNOTIMPL_DIR)/libnotimpl.a
+install: $(STAGING_DIR)/usr/lib/libnotimpl.a
+clean: 
+       rm -rf \
+               $(STAGING_DIR)/usr/lib/libnotimpl.a \
+               $(LIBNOTIMPL_DIR) \
diff --git a/toolchain/libnotimpl/files/math.c b/toolchain/libnotimpl/files/math.c
new file mode 100644 (file)
index 0000000..cc8a661
--- /dev/null
@@ -0,0 +1,35 @@
+/* vi: set sw=4 ts=4: */
+
+/* cosf for uClibc
+ *
+ * wrapper for cos(x)
+ */
+
+#include "math.h"
+
+#ifdef __STDC__
+       float cosf(float x)             /* wrapper cos */
+#else
+       float cosf(x)                   /* wrapper cos */
+       float x;
+#endif
+{
+       return (float) cos( (double)x );
+}
+
+/* sinf for uClibc
+ *
+ * wrapper for sin(x)
+ */
+
+#include "math.h"
+
+#ifdef __STDC__
+       float sinf(float x)             /* wrapper sin */
+#else
+       float sinf(x)                   /* wrapper sin */
+       float x;
+#endif
+{
+       return (float) sin( (double)x );
+}