add descriptions to the broadcom target profiles and export them to the target metada...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Jan 2007 02:30:36 +0000 (02:30 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Jan 2007 02:30:36 +0000 (02:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6137 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-build.mk
scripts/metadata.pl
target/linux/brcm-2.4/Makefile
target/linux/brcm-2.6/Makefile

index 6d9c9d9..9a1e363 100644 (file)
@@ -206,10 +206,15 @@ endef
 define Profile
   $(eval $(call Profile/Default))
   $(eval $(call Profile/$(1)))
+  $(eval $(call shexport,Profile/$(1)/Description))
   DUMPINFO += \
        echo "Target-Profile: $(1)"; \
        echo "Target-Profile-Name: $(NAME)"; \
-       echo "Target-Profile-Packages: $(PACKAGES)"; 
+       echo "Target-Profile-Packages: $(PACKAGES)"; \
+       echo "Target-Profile-Description:"; \
+       getvar "$(call shvar,Profile/$(1)/Description)"; \
+       echo "@@"; \
+       echo;
 endef
 
 $(eval $(call shexport,Target/Description))
index 9434af0..396954a 100755 (executable)
@@ -45,6 +45,14 @@ sub parse_target_metadata() {
                };
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
+               /^Target-Profile-Description:/ and do {
+                       my $desc;
+                       while (<>) {
+                               last if /^@@/;
+                               $desc .= $_;
+                       }
+                       $profile->{desc} = $desc;
+               };
        }
        foreach my $target (@target) {
                @{$target->{profiles}} > 0 or $target->{profiles} = [
index 82bfa1b..0091360 100644 (file)
@@ -25,24 +25,40 @@ define Profile/Broadcom
   NAME:=Generic, Broadcom WiFi (default)
   PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
 endef
+
+define Profile/Broadcom/Description
+       Default package set compatible with most BCM947xx hardware
+endef
 $(eval $(call Profile,Broadcom))
 
 define Profile/BroadcomMimo
   NAME:=Generic, Broadcom WiFi (MIMO)
   PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
 endef
+
+define Profile/BroadcomMimo/Description
+       Default package set compatible with 802.11n (draft) hardware
+endef
 $(eval $(call Profile,BroadcomMimo))
 
 define Profile/Atheros
   NAME:=Generic, Atheros WiFi
   PACKAGES:=kmod-madwifi
 endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
 $(eval $(call Profile,Atheros))
 
 define Profile/None
   NAME:=Generic, No WiFi
   PACKAGES:=
 endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
 $(eval $(call Profile,None))
 
 
@@ -50,30 +66,50 @@ define Profile/WRT54G3G
   NAME:=Linksys WRT54G3G
   PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
 endef
+
+define Profile/WRT54G3G/Description
+       Package set optimized for the WRT54G3G with UMTS support
+endef
 $(eval $(call Profile,WRT54G3G))
 
 define Profile/WL500G
   NAME:=ASUS WL-500g
   PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
 endef
+
+define Profile/WL500G/Description
+       Package set optimized for the WL-500g with USB and parallel port support
+endef
 $(eval $(call Profile,WL500G))
 
 define Profile/WL500GD
   NAME:=ASUS WL-500g Deluxe
   PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
 endef
+
+define Profile/WL500GD/Description
+       Package set optimized for the WL-500g Deluxe with USB support
+endef
 $(eval $(call Profile,WL500GD))
 
 define Profile/WL500GP
   NAME:=ASUS WL-500g Premium
   PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
 endef
+
+define Profile/WL500GP/Description
+       Package set optimized for the WL-500g Premium with USB support
+endef
 $(eval $(call Profile,WL500GP))
 
 define Profile/WLHDD
   NAME:=WL-HDD
   PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
 endef
+
+define Profile/WLHDD/Description
+       Package set optimized for the WL-HDD with USB and IDE support
+endef
 $(eval $(call Profile,WLHDD))
 
 $(eval $(call BuildKernel))
index 0a25759..0d55331 100644 (file)
@@ -23,12 +23,20 @@ define Profile/Atheros
   NAME:=Atheros WiFi (default)
   PACKAGES:=kmod-madwifi
 endef
+
+define Profile/Atheros/Description
+       Package set compatible with hardware using Atheros WiFi cards
+endef
 $(eval $(call Profile,Atheros))
 
 define Profile/None
   NAME:=No WiFi
   PACKAGES:=
 endef
+
+define Profile/None/Description
+       Package set without WiFi support
+endef
 $(eval $(call Profile,None))
 
 $(eval $(call BuildKernel))