kernel/modules: add kmod-crypto-ctr
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Jan 2015 13:01:52 +0000 (13:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Jan 2015 13:01:52 +0000 (13:01 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43834 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/crypto.mk

index 3193fb0..1fd10d9 100644 (file)
@@ -303,6 +303,17 @@ endef
 
 $(eval $(call KernelPackage,crypto-cbc))
 
+define KernelPackage/crypto-ctr
+  TITLE:=Counter Mode CryptoAPI module
+  DEPENDS:=+kmod-crypto-manager +kmod-crypto-seqiv
+  KCONFIG:=CONFIG_CRYPTO_CTR
+  FILES:=$(LINUX_DIR)/crypto/ctr.ko
+  AUTOLOAD:=$(call AutoLoad,09,ctr)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-ctr))
+
 define KernelPackage/crypto-pcbc
   TITLE:=Propagating Cipher Block Chaining CryptoAPI module
   DEPENDS:=+kmod-crypto-manager