cns21xx: print image build warnings/errors to stderr
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Feb 2013 11:45:31 +0000 (11:45 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 21 Feb 2013 11:45:31 +0000 (11:45 +0000)
Makes warnings/errors visible when building with V=w/V=1.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35720 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/cns21xx/image/Makefile

index 711a85e..dd2d5d0 100644 (file)
@@ -66,9 +66,9 @@ endef
 
 define Image/Build/Generic
        if [ `stat -c%s "$(KDIR)/$(call zimage_name,$(2))"` -gt 1048576 ]; then \
-               echo "Warning: $(KDIR)/$(call zimage_name,$(2)) is too big"; \
+               echo "Warning: $(KDIR)/$(call zimage_name,$(2)) is too big" >&2; \
        else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(3) ]; then \
-               echo "Warning: of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) is too big"; \
+               echo "Warning: of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) is too big" >&2; \
        else \
                cat $(KDIR)/root.$(1) > $(call rootfsname,$(1),$(2)); \
                ( \
@@ -80,9 +80,9 @@ endef
 
 define Image/Build/uImage
        if [ `stat -c%s "$(KDIR)/$(call uimage_name,$(2))"` -gt 1048576 ]; then \
-               echo "Warning: $(KDIR)/$(call uimage_name,$(2)) is too big"; \
+               echo "Warning: $(KDIR)/$(call uimage_name,$(2)) is too big" >&2; \
        else if [ `stat -c%s $(KDIR)/root.$(1)` -gt $(3) ]; then \
-               echo "Warning: of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) is too big"; \
+               echo "Warning: of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) is too big" >&2; \
        else \
                cat $(KDIR)/root.$(1) > $(call rootfsname,$(1),$(2)); \
                ( \