ar71xx: add support for buffalo WZR-450HP2
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Oct 2014 11:02:18 +0000 (11:02 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 22 Oct 2014 11:02:18 +0000 (11:02 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43026 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/base-files/etc/uci-defaults/02_network
target/linux/ar71xx/base-files/lib/ar71xx.sh
target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/config-3.10
target/linux/ar71xx/config-3.14
target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-450hp2.c [new file with mode: 0644]
target/linux/ar71xx/generic/profiles/buffalo.mk
target/linux/ar71xx/image/Makefile
target/linux/ar71xx/patches-3.14/729-MIPS-ath79-add-WZR-450HP2.patch [new file with mode: 0644]

index fdbca51..743f9de 100755 (executable)
@@ -46,7 +46,8 @@ ap136-010)
 
 ap136-020 |\
 ap135-020 |\
-tl-wr1043nd-v2)
+tl-wr1043nd-v2 |\
+wzr-450hp2)
        ucidef_set_interfaces_lan_wan "eth1" "eth0"
        ucidef_add_switch "switch0" "1" "1"
        ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 4"
index 378a619..40e9303 100755 (executable)
@@ -716,6 +716,9 @@ ar71xx_board_detect() {
        *WRT400N)
                name="wrt400n"
                ;;
+       *"WZR-450HP2")
+               name="wzr-450hp2"
+               ;;
        *"WZR-HP-AG300H/WZR-600DHP")
                name="wzr-hp-ag300h"
                ;;
index b8b2fa9..6220f16 100755 (executable)
@@ -200,6 +200,7 @@ platform_check_image() {
        wzr-hp-g300nh | \
        wzr-hp-g450h | \
        wzr-hp-ag300h | \
+       wzr-450hp2 | \
        whr-g301n | \
        whr-hp-g300n | \
        whr-hp-gn | \
index 48ff491..1b3eddb 100644 (file)
@@ -123,6 +123,7 @@ CONFIG_ATH79_MACH_WP543=y
 CONFIG_ATH79_MACH_WPE72=y
 CONFIG_ATH79_MACH_WRT160NL=y
 CONFIG_ATH79_MACH_WRT400N=y
+CONFIG_ATH79_MACH_WZR_450HP2=y
 CONFIG_ATH79_MACH_WZR_HP_AG300H=y
 CONFIG_ATH79_MACH_WZR_HP_G300NH=y
 CONFIG_ATH79_MACH_WZR_HP_G300NH2=y
index 0996ccb..cc995f4 100644 (file)
@@ -124,6 +124,7 @@ CONFIG_ATH79_MACH_WP543=y
 CONFIG_ATH79_MACH_WPE72=y
 CONFIG_ATH79_MACH_WRT160NL=y
 CONFIG_ATH79_MACH_WRT400N=y
+CONFIG_ATH79_MACH_WZR_450HP2=y
 CONFIG_ATH79_MACH_WZR_HP_AG300H=y
 CONFIG_ATH79_MACH_WZR_HP_G300NH=y
 CONFIG_ATH79_MACH_WZR_HP_G300NH2=y
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-450hp2.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-wzr-450hp2.c
new file mode 100644 (file)
index 0000000..428876f
--- /dev/null
@@ -0,0 +1,221 @@
+/*
+ * Buffalo WZR-450HP2 board support
+ *
+ * Copyright (c) 2013 Gabor Juhos <juhosg@openwrt.org>
+ *
+ * Based on the Qualcomm Atheros AP135/AP136 reference board support code
+ *   Copyright (c) 2012 Qualcomm Atheros
+ *
+ * Permission to use, copy, modify, and/or distribute this software for any
+ * purpose with or without fee is hereby granted, provided that the above
+ * copyright notice and this permission notice appear in all copies.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
+ * WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
+ * MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
+ * ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
+ * WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
+ * ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
+ * OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+ *
+ */
+
+#include <linux/phy.h>
+#include <linux/gpio.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/platform_device.h>
+#include <linux/ar8216_platform.h>
+
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-spi.h"
+#include "dev-usb.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define WZR_450HP2_KEYS_POLL_INTERVAL  20      /* msecs */
+#define WZR_450HP2_KEYS_DEBOUNCE_INTERVAL (3 * WZR_450HP2_KEYS_POLL_INTERVAL)
+
+#define WZR_450HP2_WMAC_CALDATA_OFFSET 0x1000
+
+static struct mtd_partition wzrhpg450h_partitions[] = {
+       {
+               .name           = "u-boot",
+               .offset         = 0,
+               .size           = 0x0040000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "u-boot-env",
+               .offset         = 0x0040000,
+               .size           = 0x0010000,
+       }, {
+               .name           = "ART",
+               .offset         = 0x0ff0000,
+               .size           = 0x0010000,
+               .mask_flags     = MTD_WRITEABLE,
+       }, {
+               .name           = "firmware",
+               .offset         = 0x0050000,
+               .size           = 0x0f90000,
+       }, {
+               .name           = "user_property",
+               .offset         = 0x0fe0000,
+               .size           = 0x0010000,
+       }
+};
+
+static struct flash_platform_data wzr_450hp2_flash_data = {
+       .parts          = wzrhpg450h_partitions,
+       .nr_parts       = ARRAY_SIZE(wzrhpg450h_partitions),
+};
+
+static struct gpio_led wzr_450hp2_leds_gpio[] __initdata = {
+       {
+               .name           = "buffalo:green:wps",
+               .gpio           = 3,
+               .active_low     = 1,
+       },
+       {
+               .name           = "buffalo:green:system",
+               .gpio           = 20,
+               .active_low     = 1,
+       },
+       {
+               .name           = "buffalo:green:wlan",
+               .gpio           = 18,
+               .active_low     = 1,
+       },
+};
+
+static struct gpio_keys_button wzr_450hp2_gpio_keys[] __initdata = {
+       {
+               .desc           = "Reset button",
+               .type           = EV_KEY,
+               .code           = KEY_RESTART,
+               .debounce_interval = WZR_450HP2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = 17,
+               .active_low     = 1,
+       },
+       {
+               .desc           = "RFKILL button",
+               .type           = EV_KEY,
+               .code           = KEY_RFKILL,
+               .debounce_interval = WZR_450HP2_KEYS_DEBOUNCE_INTERVAL,
+               .gpio           = 21,
+               .active_low     = 1,
+       },
+};
+
+static const struct ar8327_led_info wzr_450hp2_leds_ar8327[] = {
+       AR8327_LED_INFO(PHY0_0, HW, "buffalo:green:lan1"),
+       AR8327_LED_INFO(PHY1_0, HW, "buffalo:green:lan2"),
+       AR8327_LED_INFO(PHY2_0, HW, "buffalo:green:lan3"),
+       AR8327_LED_INFO(PHY3_0, HW, "buffalo:green:lan4"),
+       AR8327_LED_INFO(PHY4_0, HW, "buffalo:green:wan"),
+};
+
+/* GMAC0 of the AR8327 switch is connected to the QCA9558 SoC via SGMII */
+static struct ar8327_pad_cfg wzr_450hp2_ar8327_pad0_cfg = {
+       .mode = AR8327_PAD_MAC_SGMII,
+       .sgmii_delay_en = true,
+};
+
+/* GMAC6 of the AR8327 switch is connected to the QCA9558 SoC via RGMII */
+static struct ar8327_pad_cfg wzr_450hp2_ar8327_pad6_cfg = {
+       .mode = AR8327_PAD_MAC_RGMII,
+       .txclk_delay_en = true,
+       .rxclk_delay_en = true,
+       .txclk_delay_sel = AR8327_CLK_DELAY_SEL1,
+       .rxclk_delay_sel = AR8327_CLK_DELAY_SEL2,
+};
+
+static struct ar8327_led_cfg wzr_450hp2_ar8327_led_cfg = {
+       .led_ctrl0 = 0xcc35cc35,
+       .led_ctrl1 = 0xca35ca35,
+       .led_ctrl2 = 0xc935c935,
+       .led_ctrl3 = 0x03ffff00,
+       .open_drain = true,
+};
+
+static struct ar8327_platform_data wzr_450hp2_ar8327_data = {
+       .pad0_cfg = &wzr_450hp2_ar8327_pad0_cfg,
+       .pad6_cfg = &wzr_450hp2_ar8327_pad6_cfg,
+       .port0_cfg = {
+               .force_link = 1,
+               .speed = AR8327_PORT_SPEED_1000,
+               .duplex = 1,
+               .txpause = 1,
+               .rxpause = 1,
+       },
+       .port6_cfg = {
+               .force_link = 1,
+               .speed = AR8327_PORT_SPEED_1000,
+               .duplex = 1,
+               .txpause = 1,
+               .rxpause = 1,
+       },
+       .led_cfg = &wzr_450hp2_ar8327_led_cfg,
+       .num_leds = ARRAY_SIZE(wzr_450hp2_leds_ar8327),
+       .leds = wzr_450hp2_leds_ar8327,
+};
+
+static struct mdio_board_info wzr_450hp2_mdio0_info[] = {
+       {
+               .bus_id = "ag71xx-mdio.0",
+               .phy_addr = 0,
+               .platform_data = &wzr_450hp2_ar8327_data,
+       },
+};
+
+static void __init wzr_450hp2_setup(void)
+{
+       u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+       u8 *mac_wan = art;
+       u8 *mac_lan = mac_wan + ETH_ALEN;
+
+       ath79_register_m25p80(&wzr_450hp2_flash_data);
+
+       ath79_register_leds_gpio(-1, ARRAY_SIZE(wzr_450hp2_leds_gpio),
+                                wzr_450hp2_leds_gpio);
+       ath79_register_gpio_keys_polled(-1, WZR_450HP2_KEYS_POLL_INTERVAL,
+                                       ARRAY_SIZE(wzr_450hp2_gpio_keys),
+                                       wzr_450hp2_gpio_keys);
+
+       ath79_register_wmac(art + WZR_450HP2_WMAC_CALDATA_OFFSET, mac_lan);
+
+       mdiobus_register_board_info(wzr_450hp2_mdio0_info,
+                                   ARRAY_SIZE(wzr_450hp2_mdio0_info));
+       ath79_register_mdio(0, 0x0);
+
+       ath79_setup_qca955x_eth_cfg(QCA955X_ETH_CFG_RGMII_EN);
+
+       /* GMAC0 is connected to the RMGII interface */
+       ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+       ath79_eth0_data.phy_mask = BIT(0);
+       ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+       ath79_eth0_pll_data.pll_1000 = 0x56000000;
+
+       ath79_init_mac(ath79_eth0_data.mac_addr, mac_wan, 0);
+       ath79_register_eth(0);
+
+       /* GMAC1 is connected to the SGMII interface */
+       ath79_eth1_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+       ath79_eth1_data.speed = SPEED_1000;
+       ath79_eth1_data.duplex = DUPLEX_FULL;
+       ath79_eth1_pll_data.pll_1000 = 0x03000101;
+
+       ath79_init_mac(ath79_eth1_data.mac_addr, mac_lan, 0);
+       ath79_register_eth(1);
+
+       ath79_register_usb();
+}
+
+MIPS_MACHINE(ATH79_MACH_WZR_450HP2, "WZR-450HP2",
+            "Buffalo WZR-450HP2", wzr_450hp2_setup);
+
index 80e7192..900f6a8 100644 (file)
@@ -49,6 +49,17 @@ endef
 
 $(eval $(call Profile,WZRHPG450H))
 
+define Profile/WZR450HP2
+       NAME:=Buffalo WZR-450HP2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WZR450HP2/Description
+       Package set optimized for the Buffalo WZR-450HP2
+endef
+
+$(eval $(call Profile,WZR450HP2))
+
 define Profile/WZR600DHP
        NAME:=Buffalo WZR-600DHP
        PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
index f0e6586..3256cb8 100644 (file)
@@ -1284,6 +1284,7 @@ $(eval $(call SingleProfile,WZRHP64K,64kraw,WZRHPG300NH2,wzr-hp-g300nh2,WZR-HP-G
 $(eval $(call SingleProfile,WZRHP64K,64kraw,WZRHPAG300H,wzr-hp-ag300h,WZR-HP-AG300H,ttyS0,115200,WZR-HP-AG300H))
 $(eval $(call SingleProfile,WZRHP64K,64kraw,WZRHPG450H,wzr-hp-g450h,WZR-HP-G450H,ttyS0,115200,WZR-HP-AG450H))
 $(eval $(call SingleProfile,WZRHP64K,64kraw,WZR600DHP,wzr-600dhp,WZR-HP-AG300H,ttyS0,115200,WZR-600DHP))
+$(eval $(call SingleProfile,WZRHP64K,64kraw,WZR450HP2,wzr-450hp2,WZR-450HP2,ttyS0,115200,WZR-450HP2))
 
 $(eval $(call SingleProfile,Zcomax,64k,ZCN1523H28,zcn-1523h-2-8,ZCN-1523H-2,ttyS0,115200,$$(zcn1523h_mtdlayout)))
 $(eval $(call SingleProfile,Zcomax,64k,ZCN1523H516,zcn-1523h-5-16,ZCN-1523H-5,ttyS0,115200,$$(zcn1523h_mtdlayout)))
diff --git a/target/linux/ar71xx/patches-3.14/729-MIPS-ath79-add-WZR-450HP2.patch b/target/linux/ar71xx/patches-3.14/729-MIPS-ath79-add-WZR-450HP2.patch
new file mode 100644 (file)
index 0000000..d7364e4
--- /dev/null
@@ -0,0 +1,39 @@
+--- a/arch/mips/ath79/machtypes.h
++++ b/arch/mips/ath79/machtypes.h
+@@ -182,6 +182,7 @@ enum ath79_mach_type {
+       ATH79_MACH_WZR_HP_G300NH,       /* Buffalo WZR-HP-G300NH */
+       ATH79_MACH_WZR_HP_G300NH2,      /* Buffalo WZR-HP-G300NH2 */
+       ATH79_MACH_WZR_HP_G450H,        /* Buffalo WZR-HP-G450H */
++      ATH79_MACH_WZR_450HP2,          /* Buffalo WZR-450HP2 */
+       ATH79_MACH_ZCN_1523H_2,         /* Zcomax ZCN-1523H-2-xx */
+       ATH79_MACH_ZCN_1523H_5,         /* Zcomax ZCN-1523H-5-xx */
+ };
+--- a/arch/mips/ath79/Kconfig
++++ b/arch/mips/ath79/Kconfig
+@@ -263,6 +263,16 @@ config ATH79_MACH_WZR_HP_G450H
+       select ATH79_DEV_M25P80
+       select ATH79_DEV_USB
++config ATH79_MACH_WZR_450HP2
++      bool "Buffalo WZR-450HP2 board support"
++      select SOC_QCA955X
++      select ATH79_DEV_ETH
++      select ATH79_DEV_GPIO_BUTTONS
++      select ATH79_DEV_LEDS_GPIO
++      select ATH79_DEV_M25P80
++      select ATH79_DEV_USB
++      select ATH79_DEV_WMAC
++
+ config ATH79_MACH_WP543
+       bool "Compex WP543/WPJ543 board support"
+       select SOC_AR71XX
+--- a/arch/mips/ath79/Makefile
++++ b/arch/mips/ath79/Makefile
+@@ -140,6 +140,7 @@ obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH)     +
+ obj-$(CONFIG_ATH79_MACH_WZR_HP_G300NH2)       += mach-wzr-hp-g300nh2.o
+ obj-$(CONFIG_ATH79_MACH_WZR_HP_AG300H)        += mach-wzr-hp-ag300h.o
+ obj-$(CONFIG_ATH79_MACH_WZR_HP_G450H) += mach-wzr-hp-g450h.o
++obj-$(CONFIG_ATH79_MACH_WZR_450HP2)   += mach-wzr-450hp2.o
+ obj-$(CONFIG_ATH79_MACH_ZCN_1523H)    += mach-zcn-1523h.o
+ obj-$(CONFIG_ATH79_MACH_CARAMBOLA2)   += mach-carambola2.o
+ obj-$(CONFIG_ATH79_MACH_NBG6716)      += mach-nbg6716.o