samba: don't overwrite config file
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Apr 2015 13:39:23 +0000 (13:39 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Apr 2015 13:39:23 +0000 (13:39 +0000)
fixes #19087

Signed-off-by: John Crispin <blogic@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45220 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/samba36/Makefile

index 70dfb2b..a3daf58 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=samba
 PKG_VERSION:=3.6.25
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://ftp.samba.org/pub/samba \
        http://ftp.samba.org/pub/samba/stable
@@ -123,10 +123,14 @@ CONFIGURE_ARGS += \
 
 MAKE_FLAGS += DYNEXP= PICFLAG= MODULES=
 
+define Package/samba36-server/conffiles
+/etc/config/samba
+endef
+
 define Package/samba36-server/install
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_DATA) ./files/samba.config $(1)/etc/config/samba
-       $(INSTALL_DIR) $(1)/etc/samba
+       $(INSTALL_CONF) $(1)/etc/samba
        $(INSTALL_DATA) ./files/smb.conf.template $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/lowcase.dat $(1)/etc/samba
        $(INSTALL_DATA) $(PKG_BUILD_DIR)/codepages/upcase.dat $(1)/etc/samba