lzo: disable unaligned access for everything except x86
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Nov 2014 20:10:02 +0000 (20:10 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 23 Nov 2014 20:10:02 +0000 (20:10 +0000)
Fixes issues on ARM

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43349 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/lzo/Makefile

index b2bab05..6a88a6f 100644 (file)
@@ -45,6 +45,10 @@ endef
 TARGET_CFLAGS += $(FPIC)
 MAKE_FLAGS += CFLAGS_O="$(TARGET_CFLAGS)"
 
+ifeq ($(CONFIG_i386)$(CONFIG_x86_64),)
+  TARGET_CFLAGS += -DLZO_CFG_NO_UNALIGNED=1
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(1)/usr/include/