Rename patches to match conventions
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jan 2007 17:28:16 +0000 (17:28 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 11 Jan 2007 17:28:16 +0000 (17:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6080 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/bridge/patches/01-patch-libbridge_makefile_in [new file with mode: 0644]
package/bridge/patches/patch-libbridge_Makefile_in [deleted file]
package/ipset/patches/01-kernel_26.patch [new file with mode: 0644]
package/ipset/patches/kernel26.patch [deleted file]
package/wireless-tools/patches/01-debian.patch [new file with mode: 0644]
package/wireless-tools/patches/debian-2.patch [deleted file]

diff --git a/package/bridge/patches/01-patch-libbridge_makefile_in b/package/bridge/patches/01-patch-libbridge_makefile_in
new file mode 100644 (file)
index 0000000..f447377
--- /dev/null
@@ -0,0 +1,11 @@
+--- bridge-utils-0.9.6/libbridge/Makefile.in.dist      2004-03-01 20:55:52.000000000 -0600
++++ bridge-utils-0.9.6/libbridge/Makefile.in   2004-03-01 20:56:23.000000000 -0600
+@@ -5,7 +5,7 @@
+ RANLIB=@RANLIB@
+ CC=@CC@
+-CFLAGS = -Wall -g $(KERNEL_HEADERS)
++CFLAGS = -Wall -g @CFLAGS@ $(KERNEL_HEADERS)
+ prefix=@prefix@
+ exec_prefix=@exec_prefix@
diff --git a/package/bridge/patches/patch-libbridge_Makefile_in b/package/bridge/patches/patch-libbridge_Makefile_in
deleted file mode 100644 (file)
index f447377..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- bridge-utils-0.9.6/libbridge/Makefile.in.dist      2004-03-01 20:55:52.000000000 -0600
-+++ bridge-utils-0.9.6/libbridge/Makefile.in   2004-03-01 20:56:23.000000000 -0600
-@@ -5,7 +5,7 @@
- RANLIB=@RANLIB@
- CC=@CC@
--CFLAGS = -Wall -g $(KERNEL_HEADERS)
-+CFLAGS = -Wall -g @CFLAGS@ $(KERNEL_HEADERS)
- prefix=@prefix@
- exec_prefix=@exec_prefix@
diff --git a/package/ipset/patches/01-kernel_26.patch b/package/ipset/patches/01-kernel_26.patch
new file mode 100644 (file)
index 0000000..46112ab
--- /dev/null
@@ -0,0 +1,66 @@
+diff -Nur ipset-2.2.3.orig/ipset.c ipset-2.2.3/ipset.c
+--- ipset-2.2.3.orig/ipset.c   2005-04-05 09:56:02.000000000 +0200
++++ ipset-2.2.3/ipset.c        2005-09-29 13:07:07.446923250 +0200
+@@ -21,7 +21,6 @@
+ #include <stdarg.h>
+ #include <netdb.h>
+ #include <dlfcn.h>
+-#include <asm/bitops.h>
+ #include "ipset.h"
+diff -Nur ipset-2.2.3.orig/ipset_iphash.c ipset-2.2.3/ipset_iphash.c
+--- ipset-2.2.3.orig/ipset_iphash.c    2005-01-19 14:38:57.000000000 +0100
++++ ipset-2.2.3/ipset_iphash.c 2005-09-29 13:07:26.308102000 +0200
+@@ -25,7 +25,6 @@
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-#include <asm/bitops.h>
+ #include <asm/types.h>
+ #include <linux/netfilter_ipv4/ip_set_iphash.h>
+diff -Nur ipset-2.2.3.orig/ipset_ipmap.c ipset-2.2.3/ipset_ipmap.c
+--- ipset-2.2.3.orig/ipset_ipmap.c     2005-01-19 14:38:57.000000000 +0100
++++ ipset-2.2.3/ipset_ipmap.c  2005-09-29 13:07:07.446923250 +0200
+@@ -22,7 +22,6 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-#include <asm/bitops.h>
+ #include <linux/netfilter_ipv4/ip_set_ipmap.h>
+ #include "ipset.h"
+diff -Nur ipset-2.2.3.orig/ipset_macipmap.c ipset-2.2.3/ipset_macipmap.c
+--- ipset-2.2.3.orig/ipset_macipmap.c  2005-01-19 14:38:57.000000000 +0100
++++ ipset-2.2.3/ipset_macipmap.c       2005-09-29 13:07:07.446923250 +0200
+@@ -24,7 +24,6 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-#include <asm/bitops.h>
+ #include <linux/if_ether.h>
+ #include <linux/netfilter_ipv4/ip_set_macipmap.h>
+diff -Nur ipset-2.2.3.orig/ipset_nethash.c ipset-2.2.3/ipset_nethash.c
+--- ipset-2.2.3.orig/ipset_nethash.c   2005-05-09 07:44:25.000000000 +0200
++++ ipset-2.2.3/ipset_nethash.c        2005-09-29 13:07:07.446923250 +0200
+@@ -25,7 +25,6 @@
+ #include <sys/types.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-#include <asm/bitops.h>
+ #include <asm/types.h>
+ #include <linux/netfilter_ipv4/ip_set_nethash.h>
+diff -Nur ipset-2.2.3.orig/ipset_portmap.c ipset-2.2.3/ipset_portmap.c
+--- ipset-2.2.3.orig/ipset_portmap.c   2005-01-19 14:38:57.000000000 +0100
++++ ipset-2.2.3/ipset_portmap.c        2005-09-29 13:07:07.446923250 +0200
+@@ -21,7 +21,6 @@
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
+-#include <asm/bitops.h>
+ #include <linux/netfilter_ipv4/ip_set_portmap.h>
+ #include "ipset.h"
diff --git a/package/ipset/patches/kernel26.patch b/package/ipset/patches/kernel26.patch
deleted file mode 100644 (file)
index 46112ab..0000000
+++ /dev/null
@@ -1,66 +0,0 @@
-diff -Nur ipset-2.2.3.orig/ipset.c ipset-2.2.3/ipset.c
---- ipset-2.2.3.orig/ipset.c   2005-04-05 09:56:02.000000000 +0200
-+++ ipset-2.2.3/ipset.c        2005-09-29 13:07:07.446923250 +0200
-@@ -21,7 +21,6 @@
- #include <stdarg.h>
- #include <netdb.h>
- #include <dlfcn.h>
--#include <asm/bitops.h>
- #include "ipset.h"
-diff -Nur ipset-2.2.3.orig/ipset_iphash.c ipset-2.2.3/ipset_iphash.c
---- ipset-2.2.3.orig/ipset_iphash.c    2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_iphash.c 2005-09-29 13:07:26.308102000 +0200
-@@ -25,7 +25,6 @@
- #include <sys/types.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <asm/types.h>
- #include <linux/netfilter_ipv4/ip_set_iphash.h>
-diff -Nur ipset-2.2.3.orig/ipset_ipmap.c ipset-2.2.3/ipset_ipmap.c
---- ipset-2.2.3.orig/ipset_ipmap.c     2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_ipmap.c  2005-09-29 13:07:07.446923250 +0200
-@@ -22,7 +22,6 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <linux/netfilter_ipv4/ip_set_ipmap.h>
- #include "ipset.h"
-diff -Nur ipset-2.2.3.orig/ipset_macipmap.c ipset-2.2.3/ipset_macipmap.c
---- ipset-2.2.3.orig/ipset_macipmap.c  2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_macipmap.c       2005-09-29 13:07:07.446923250 +0200
-@@ -24,7 +24,6 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <linux/if_ether.h>
- #include <linux/netfilter_ipv4/ip_set_macipmap.h>
-diff -Nur ipset-2.2.3.orig/ipset_nethash.c ipset-2.2.3/ipset_nethash.c
---- ipset-2.2.3.orig/ipset_nethash.c   2005-05-09 07:44:25.000000000 +0200
-+++ ipset-2.2.3/ipset_nethash.c        2005-09-29 13:07:07.446923250 +0200
-@@ -25,7 +25,6 @@
- #include <sys/types.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <asm/types.h>
- #include <linux/netfilter_ipv4/ip_set_nethash.h>
-diff -Nur ipset-2.2.3.orig/ipset_portmap.c ipset-2.2.3/ipset_portmap.c
---- ipset-2.2.3.orig/ipset_portmap.c   2005-01-19 14:38:57.000000000 +0100
-+++ ipset-2.2.3/ipset_portmap.c        2005-09-29 13:07:07.446923250 +0200
-@@ -21,7 +21,6 @@
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
--#include <asm/bitops.h>
- #include <linux/netfilter_ipv4/ip_set_portmap.h>
- #include "ipset.h"
diff --git a/package/wireless-tools/patches/01-debian.patch b/package/wireless-tools/patches/01-debian.patch
new file mode 100644 (file)
index 0000000..ba8755b
--- /dev/null
@@ -0,0 +1,35 @@
+--- wireless-tools-27.orig/iwlib.c
++++ wireless-tools-27/iwlib.c
+@@ -622,6 +622,7 @@
+ {
+   struct iwreq                wrq;
++  memset((char *) &wrq, 0, sizeof(struct iwreq));
+   memset((char *) info, 0, sizeof(struct wireless_config));
+   /* Get wireless name */
+--- wireless-tools-27.orig/Makefile
++++ wireless-tools-27/Makefile
+@@ -64,8 +64,8 @@
+ # Install directories
+ INSTALL_DIR= $(PREFIX)/sbin/
+ INSTALL_LIB= $(PREFIX)/lib/
+-INSTALL_INC= $(PREFIX)/include/
+-INSTALL_MAN= $(PREFIX)/man/
++INSTALL_INC= $(PREFIX)/usr/include/
++INSTALL_MAN= $(PREFIX)/usr/share/man/
+ # Various commands
+ RM = rm -f
+@@ -81,9 +81,9 @@
+ endif
+ # Other flags
+-CFLAGS=-Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow \
++#CFLAGS=-Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow \
+       -Wpointer-arith -Wcast-qual -Winline -I.
+-#CFLAGS=-O2 -W -Wall -Wstrict-prototypes -I.
++CFLAGS=-O2 -W -Wall -Wstrict-prototypes -I.
+ DEPFLAGS=-MMD
+ XCFLAGS=$(CFLAGS) $(DEPFLAGS) $(WARN) $(HEADERS) $(WELIB_FLAG)
+ PICFLAG=-fPIC
diff --git a/package/wireless-tools/patches/debian-2.patch b/package/wireless-tools/patches/debian-2.patch
deleted file mode 100644 (file)
index ba8755b..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
---- wireless-tools-27.orig/iwlib.c
-+++ wireless-tools-27/iwlib.c
-@@ -622,6 +622,7 @@
- {
-   struct iwreq                wrq;
-+  memset((char *) &wrq, 0, sizeof(struct iwreq));
-   memset((char *) info, 0, sizeof(struct wireless_config));
-   /* Get wireless name */
---- wireless-tools-27.orig/Makefile
-+++ wireless-tools-27/Makefile
-@@ -64,8 +64,8 @@
- # Install directories
- INSTALL_DIR= $(PREFIX)/sbin/
- INSTALL_LIB= $(PREFIX)/lib/
--INSTALL_INC= $(PREFIX)/include/
--INSTALL_MAN= $(PREFIX)/man/
-+INSTALL_INC= $(PREFIX)/usr/include/
-+INSTALL_MAN= $(PREFIX)/usr/share/man/
- # Various commands
- RM = rm -f
-@@ -81,9 +81,9 @@
- endif
- # Other flags
--CFLAGS=-Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow \
-+#CFLAGS=-Os -W -Wall -Wstrict-prototypes -Wmissing-prototypes -Wshadow \
-       -Wpointer-arith -Wcast-qual -Winline -I.
--#CFLAGS=-O2 -W -Wall -Wstrict-prototypes -I.
-+CFLAGS=-O2 -W -Wall -Wstrict-prototypes -I.
- DEPFLAGS=-MMD
- XCFLAGS=$(CFLAGS) $(DEPFLAGS) $(WARN) $(HEADERS) $(WELIB_FLAG)
- PICFLAG=-fPIC