mdadm: use -ffunction-sections, -fdata-sections, --gc-sections
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jun 2013 11:26:40 +0000 (11:26 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 28 Jun 2013 11:26:40 +0000 (11:26 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37062 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/mdadm/Makefile

index af16048..6c4145a 100644 (file)
@@ -33,6 +33,9 @@ define Package/mdadm/description
  A tool for managing Linux Software RAID arrays.
 endef
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \