use 127.0.0.1 as dns server and point dnsmasq to /tmp/resolv.conf
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Jul 2006 18:12:30 +0000 (18:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 25 Jul 2006 18:12:30 +0000 (18:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4282 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/default/etc/resolv.conf [new file with mode: 0644]
package/dnsmasq/files/dnsmasq.conf

index 8fccf79..01ea967 100644 (file)
@@ -153,7 +153,6 @@ define Package/base-files$(TARGET)/install
        mkdir -p $(1)/usr/bin
        mkdir -p $(1)/sys
        mkdir -p $(1)/www
-       ln -sf /tmp/resolv.conf $(1)/etc/resolv.conf
        ln -sf /proc/mounts $(1)/etc/mtab
        rm -f $(1)/var
        ln -sf /tmp $(1)/var
diff --git a/package/base-files/default/etc/resolv.conf b/package/base-files/default/etc/resolv.conf
new file mode 100644 (file)
index 0000000..9617eac
--- /dev/null
@@ -0,0 +1,2 @@
+nameserver 127.0.0.1
+search lan
index 7aed3a3..43acd85 100644 (file)
@@ -8,6 +8,7 @@ localise-queries
 local=/lan/
 domain=lan
 expand-hosts
+resolv-file=/tmp/resolv.conf
 
 @ifdef dhcp_enable
 dhcp-range=@@start@@,@@end@@,@@netmask@@,@@lease@@