ar71xx: always enable hw ecc support for the ar934x-nfc module
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Nov 2013 18:33:18 +0000 (18:33 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Nov 2013 18:33:18 +0000 (18:33 +0000)
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38634 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/modules.mk

index 83747d6..4530708 100644 (file)
@@ -40,7 +40,9 @@ $(eval $(call KernelPackage,leds-wndr3700-usb))
 define KernelPackage/nand-ar934x
   SUBMENU:=$(OTHER_MENU)
   TITLE:=Atheros AR934x NAND flash controller driver
-  KCONFIG:=CONFIG_MTD_NAND_AR934X
+  KCONFIG:=\
+    CONFIG_MTD_NAND_AR934X \
+    CONFIG_MTD_NAND_AR934X_HW_ECC=y
   DEPENDS:=@TARGET_ar71xx +kmod-nand
   FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
   AUTOLOAD:=$(call AutoLoad,25,ar934x_nfc)