kernel: add some missing config options
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 31 Oct 2014 23:43:10 +0000 (23:43 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 31 Oct 2014 23:43:10 +0000 (23:43 +0000)
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43136 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk
target/linux/generic/config-3.18

index 2f9831b..ce22819 100644 (file)
@@ -764,7 +764,8 @@ define KernelPackage/zram
        CONFIG_ZSMALLOC \
        CONFIG_ZRAM \
        CONFIG_ZRAM_DEBUG=n \
-       CONFIG_PGTABLE_MAPPING=n
+       CONFIG_PGTABLE_MAPPING=n \
+       CONFIG_ZRAM_LZ4_COMPRESS=y
 ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.14.0)),1)
   FILES:=\
        $(LINUX_DIR)/mm/zsmalloc.ko \
index d24ae65..8ce457f 100644 (file)
@@ -99,7 +99,9 @@ CONFIG_AIO=y
 # CONFIG_AIRO is not set
 # CONFIG_AIRO_CS is not set
 # CONFIG_AIX_PARTITION is not set
+# CONFIG_AK09911 is not set
 # CONFIG_AK8975 is not set
+# CONFIG_AL3320A is not set
 # CONFIG_ALCHEMY_GPIO_INDIRECT is not set
 # CONFIG_ALIM7101_WDT is not set
 # CONFIG_ALTERA_STAPL is not set
@@ -239,6 +241,7 @@ CONFIG_ARM_DMA_MEM_BUFFERABLE=y
 # CONFIG_ARM_VIRT_EXT is not set
 CONFIG_ARPD=y
 # CONFIG_ARTHUR is not set
+# CONFIG_AS3935 is not set
 # CONFIG_ASUS_OLED is not set
 # CONFIG_ASYMMETRIC_KEY_TYPE is not set
 # CONFIG_ASYNC_RAID6_TEST is not set
@@ -273,6 +276,7 @@ CONFIG_ATH_CARDS=m
 # CONFIG_ATL2 is not set
 # CONFIG_ATM is not set
 # CONFIG_ATMEL is not set
+# CONFIG_ATMEL_PIT is not set
 # CONFIG_ATMEL_PWM is not set
 # CONFIG_ATMEL_SSC is not set
 # CONFIG_ATM_AMBASSADOR is not set
@@ -449,6 +453,8 @@ CONFIG_BLK_DEV_LOOP_MIN_COUNT=8
 # CONFIG_BLK_DEV_XIP is not set
 CONFIG_BLOCK=y
 # CONFIG_BMA180 is not set
+# CONFIG_BMC150_ACCEL is not set
+# CONFIG_BMG160 is not set
 # CONFIG_BMP085 is not set
 # CONFIG_BMP085_I2C is not set
 # CONFIG_BMP085_SPI is not set
@@ -529,6 +535,7 @@ CONFIG_BT_HCIUART_H4=y
 CONFIG_BT_L2CAP=y
 # CONFIG_BT_MRVL is not set
 # CONFIG_BT_RFCOMM is not set
+# CONFIG_BUILD_BIN2C is not set
 CONFIG_BT_RFCOMM_TTY=y
 CONFIG_BT_SCO=y
 CONFIG_BUG=y
@@ -759,6 +766,7 @@ CONFIG_CRYPTO_MANAGER_DISABLE_TESTS=y
 # CONFIG_CS89x0 is not set
 # CONFIG_CUSE is not set
 # CONFIG_CW1200 is not set
+# CONFIG_CXL_BASE is not set
 # CONFIG_CXT1E1 is not set
 # CONFIG_CYPRESS_FIRMWARE is not set
 # CONFIG_DAVICOM_PHY is not set
@@ -920,6 +928,7 @@ CONFIG_EFI_PARTITION=y
 # CONFIG_EFS_FS is not set
 # CONFIG_ELF_CORE is not set
 CONFIG_EMBEDDED=y
+# CONFIG_EM_TIMER_STI is not set
 # CONFIG_ENABLE_MUST_CHECK is not set
 CONFIG_ENABLE_WARN_DEPRECATED=y
 # CONFIG_ENC28J60 is not set
@@ -932,6 +941,7 @@ CONFIG_EPOLL=y
 # CONFIG_EQUALIZER is not set
 # CONFIG_ET131X is not set
 # CONFIG_GATEWORKS_GW16083 is not set
+# CONFIG_GLOB_SELFTEST is not set
 # CONFIG_GS_FPGABOOT is not set
 # CONFIG_ETH16I is not set
 CONFIG_ETHERNET=y
@@ -1176,6 +1186,7 @@ CONFIG_HAVE_KRETPROBES=y
 # CONFIG_HID_BELKIN is not set
 # CONFIG_HID_CHERRY is not set
 # CONFIG_HID_CHICONY is not set
+# CONFIG_HID_CP2112 is not set
 # CONFIG_HID_CYPRESS is not set
 # CONFIG_HID_DRAGONRISE is not set
 # CONFIG_HID_ELECOM is not set
@@ -1184,6 +1195,7 @@ CONFIG_HAVE_KRETPROBES=y
 # CONFIG_HID_EZKEY is not set
 # CONFIG_HID_GENERIC is not set
 # CONFIG_HID_GREENASIA is not set
+# CONFIG_HID_GT683R is not set
 # CONFIG_HID_GYRATION is not set
 # CONFIG_HID_HOLTEK is not set
 # CONFIG_HID_HUION is not set
@@ -1192,6 +1204,7 @@ CONFIG_HAVE_KRETPROBES=y
 # CONFIG_HID_KEYTOUCH is not set
 # CONFIG_HID_KYE is not set
 # CONFIG_HID_LCPOWER is not set
+# CONFIG_HID_LENOVO is not set
 # CONFIG_HID_LENOVO_TPKBD is not set
 # CONFIG_HID_LOGITECH is not set
 # CONFIG_HID_LOGITECH_DJ is not set
@@ -1202,6 +1215,7 @@ CONFIG_HAVE_KRETPROBES=y
 # CONFIG_HID_NTRIG is not set
 # CONFIG_HID_ORTEK is not set
 # CONFIG_HID_PANTHERLORD is not set
+# CONFIG_HID_PENMOUNT is not set
 # CONFIG_HID_PETALYNX is not set
 # CONFIG_HID_PICOLCD is not set
 # CONFIG_HID_PID is not set
@@ -1209,6 +1223,7 @@ CONFIG_HAVE_KRETPROBES=y
 # CONFIG_HID_PRODIKEYS is not set
 # CONFIG_HID_PS3REMOTE is not set
 # CONFIG_HID_QUANTA is not set
+# CONFIG_HID_RMI is not set
 # CONFIG_HID_ROCCAT is not set
 # CONFIG_HID_ROCCAT_ARVO is not set
 # CONFIG_HID_ROCCAT_KONE is not set
@@ -1640,6 +1655,7 @@ CONFIG_ISDN=y
 # CONFIG_ISDN_I4L is not set
 # CONFIG_ISL29003 is not set
 # CONFIG_ISL29020 is not set
+# CONFIG_ISL29125 is not set
 # CONFIG_ISO9660_FS is not set
 # CONFIG_ISS4xx is not set
 # CONFIG_ITG3200 is not set
@@ -1728,6 +1744,7 @@ CONFIG_KERNEL_XZ=y
 # CONFIG_KSZ884X_PCI is not set
 CONFIG_KUSER_HELPERS=y
 # CONFIG_KVM_GUEST is not set
+# CONFIG_KXCJK1013 is not set
 # CONFIG_KXSD9 is not set
 # CONFIG_L2TP is not set
 # CONFIG_L2TP_ETH is not set
@@ -1830,6 +1847,7 @@ CONFIG_LOG_CPU_MAX_BUF_SHIFT=12
 # CONFIG_LP_CONSOLE is not set
 # CONFIG_LSI_ET1011C_PHY is not set
 # CONFIG_LTE_GDM724X is not set
+# CONFIG_LTR501 is not set
 # CONFIG_LTPC is not set
 # CONFIG_LUSTRE_FS is not set
 # CONFIG_LXT_PHY is not set
@@ -1860,6 +1878,7 @@ CONFIG_LZMA_DECOMPRESS=y
 CONFIG_MAGIC_SYSRQ_DEFAULT_ENABLE=0x1
 # CONFIG_MAILBOX is not set
 # CONFIG_MARVELL_PHY is not set
+# CONFIG_MAX1027 is not set
 # CONFIG_MAX1363 is not set
 # CONFIG_MAX517 is not set
 # CONFIG_MAX63XX_WATCHDOG is not set
@@ -1867,6 +1886,7 @@ CONFIG_MAGIC_SYSRQ_DEFAULT_ENABLE=0x1
 # CONFIG_MCP320X is not set
 # CONFIG_MCP3422 is not set
 # CONFIG_MCP4725 is not set
+# CONFIG_MCP4922 is not set
 # CONFIG_MCPM is not set
 # CONFIG_MD is not set
 # CONFIG_MDIO_BCM_UNIMAC is not set
@@ -2004,6 +2024,8 @@ CONFIG_MISC_FILESYSTEMS=y
 # CONFIG_MLX4_CORE is not set
 # CONFIG_MLX4_EN is not set
 # CONFIG_MLX5_CORE is not set
+# CONFIG_MLX90614 is not set
+# CONFIG_MMA8452 is not set
 # CONFIG_MMC is not set
 # CONFIG_MMC_ARMMMCI is not set
 # CONFIG_MMC_AU1X is not set
@@ -2028,6 +2050,7 @@ CONFIG_MMC_BLOCK_MINORS=8
 # CONFIG_MMC_SPI is not set
 # CONFIG_MMC_TEST is not set
 # CONFIG_MMC_UNSAFE_RESUME is not set
+# CONFIG_MMC_USDHI6ROL0 is not set
 # CONFIG_MMC_USHC is not set
 # CONFIG_MMC_VIA_SDMMC is not set
 # CONFIG_MMC_VUB300 is not set
@@ -2049,6 +2072,7 @@ CONFIG_MODULE_UNLOAD=y
 # CONFIG_MOUSE_PS2_SENTELIC is not set
 # CONFIG_MOUSE_SYNAPTICS_I2C is not set
 # CONFIG_MOUSE_SYNAPTICS_USB is not set
+# CONFIG_MPL115 is not set
 # CONFIG_MPL3115 is not set
 # CONFIG_MSDOS_FS is not set
 CONFIG_MSDOS_PARTITION=y
@@ -2139,6 +2163,7 @@ CONFIG_MTD_NAND_IDS=y
 # CONFIG_MTD_NAND_NOMADIK is not set
 # CONFIG_MTD_NAND_NUC900 is not set
 # CONFIG_MTD_NAND_OMAP2 is not set
+# CONFIG_MTD_NAND_OMAP_BCH_BUILD is not set
 # CONFIG_MTD_NAND_ORION is not set
 # CONFIG_MTD_NAND_PASEMI is not set
 # CONFIG_MTD_NAND_PLATFORM is not set
@@ -2177,6 +2202,8 @@ CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
 CONFIG_MTD_ROOTFS_ROOT_DEV=y
 CONFIG_MTD_ROOTFS_SPLIT=y
 # CONFIG_MTD_SLRAM is not set
+# CONFIG_MTD_SM_COMMON is not set
+# CONFIG_MTD_SPI_NOR is not set
 # CONFIG_MTD_SPINAND_MT29F is not set
 CONFIG_MTD_SPLIT=y
 # CONFIG_MTD_SPLIT_FIRMWARE is not set
@@ -2363,6 +2390,7 @@ CONFIG_NET_PCI=y
 # CONFIG_NET_PKTGEN is not set
 # CONFIG_NET_POCKET is not set
 # CONFIG_NET_POLL_CONTROLLER is not set
+# CONFIG_NET_PTP_CLASSIFY is not set
 CONFIG_NET_RX_BUSY_POLL=y
 # CONFIG_NET_SB1000 is not set
 CONFIG_NET_SCHED=y
@@ -2396,6 +2424,7 @@ CONFIG_NET_SCH_FQ_CODEL=y
 # CONFIG_NET_SCH_TEQL is not set
 # CONFIG_NET_TEAM is not set
 # CONFIG_NET_TULIP is not set
+# CONFIG_NET_UDP_TUNNEL is not set
 CONFIG_NET_VENDOR_3COM=y
 CONFIG_NET_VENDOR_8390=y
 CONFIG_NET_VENDOR_ADAPTEC=y
@@ -3237,6 +3266,8 @@ CONFIG_SELECT_MEMORY_MODEL=y
 # CONFIG_SENSORS_HDAPS is not set
 # CONFIG_SENSORS_HIH6130 is not set
 # CONFIG_SENSORS_HMC5843 is not set
+# CONFIG_SENSORS_HMC5843_I2C is not set
+# CONFIG_SENSORS_HMC5843_SPI is not set
 # CONFIG_SENSORS_HTU21 is not set
 # CONFIG_SENSORS_I5K_AMB is not set
 # CONFIG_SENSORS_IIO_HWMON is not set
@@ -3392,6 +3423,10 @@ CONFIG_SERIAL_CORE_CONSOLE=y
 # CONFIG_SGI_PARTITION is not set
 CONFIG_SHMEM=y
 # CONFIG_SH_ETH is not set
+# CONFIG_SH_TIMER_CMT is not set
+# CONFIG_SH_TIMER_MTU2 is not set
+# CONFIG_SH_TIMER_TMU is not set
+# CONFIG_SI7005 is not set
 # CONFIG_SIBYTE_BIGSUR is not set
 # CONFIG_SIBYTE_CARMEL is not set
 # CONFIG_SIBYTE_CRHINE is not set
@@ -3712,6 +3747,7 @@ CONFIG_SYSVIPC=y
 CONFIG_SYSVIPC_SYSCTL=y
 # CONFIG_SYSV_FS is not set
 # CONFIG_SYS_HYPERVISOR is not set
+# CONFIG_T5403 is not set
 # CONFIG_TARGET_CORE is not set
 # CONFIG_TASKSTATS is not set
 # CONFIG_TASKS_RCU is not set
@@ -3733,6 +3769,7 @@ CONFIG_TCP_CONG_CUBIC=y
 # CONFIG_TCP_CONG_WESTWOOD is not set
 # CONFIG_TCP_CONG_YEAH is not set
 # CONFIG_TCP_MD5SIG is not set
+# CONFIG_TCS3414 is not set
 # CONFIG_TCS3472 is not set
 # CONFIG_TEGRA_HOST1X is not set
 # CONFIG_TEHUTI is not set
@@ -3765,6 +3802,7 @@ CONFIG_TIMERFD=y
 CONFIG_TINY_RCU=y
 # CONFIG_TIPC is not set
 # CONFIG_TI_ADC081C is not set
+# CONFIG_TI_ADC128S052 is not set
 # CONFIG_TI_AM335X_ADC is not set
 # CONFIG_TI_CPSW is not set
 # CONFIG_TI_CPTS is not set
@@ -3856,6 +3894,7 @@ CONFIG_UNIX98_PTYS=y
 # CONFIG_UNIXWARE_DISKLABEL is not set
 # CONFIG_UNIX_DIAG is not set
 # CONFIG_UNUSED_SYMBOLS is not set
+# CONFIG_UPROBES is not set
 # CONFIG_USB is not set
 # CONFIG_USBIP_CORE is not set
 # CONFIG_USBPCWATCHDOG is not set
@@ -4003,11 +4042,14 @@ CONFIG_USB_GADGET_VBUS_DRAW=2
 # CONFIG_USB_LCD is not set
 # CONFIG_USB_LD is not set
 # CONFIG_USB_LED is not set
+# CONFIG_USB_LED_TRIG is not set
 # CONFIG_USB_LEGOTOWER is not set
 # CONFIG_USB_LIBUSUAL is not set
+# CONFIG_USB_LINK_LAYER_TEST is not set
 # CONFIG_USB_M5602 is not set
 # CONFIG_USB_M66592 is not set
 # CONFIG_USB_MASS_STORAGE is not set
+# CONFIG_USB_MAX3421_HCD is not set
 # CONFIG_USB_MDC800 is not set
 # CONFIG_USB_MICROTEK is not set
 # CONFIG_USB_MIDI_GADGET is not set