package/busybox: fix sed issue with gcc-4.5.0 (closes #7566)
authoracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Jul 2010 11:17:41 +0000 (11:17 +0000)
committeracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 6 Jul 2010 11:17:41 +0000 (11:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22074 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile

index aa51b17..128a0de 100644 (file)
@@ -60,6 +60,10 @@ ifdef CONFIG_GCC_VERSION_LLVM
   TARGET_CFLAGS += -fnested-functions
 endif
 
+ifdef CONFIG_GCC_VERSION_4_5_0
+  TARGET_CFLAGS += -fno-tree-pta
+endif
+
 define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \