musl: fix build on sh3
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Sep 2015 17:40:44 +0000 (17:40 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 21 Sep 2015 17:40:44 +0000 (17:40 +0000)
musl fails to build when compiled with gcc on sh3 (GCC target/#67260).
Work it around.

Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47012 3c298f89-4303-0410-b956-a3cf2f4a3e73

toolchain/musl/common.mk

index 82c1543..3045c63 100644 (file)
@@ -23,6 +23,12 @@ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
 include $(INCLUDE_DIR)/toolchain-build.mk
 include $(INCLUDE_DIR)/hardening.mk
 
+# Please see https://gcc.gnu.org/bugzilla/show_bug.cgi?id=67260
+ifeq ($(CONFIG_sh3),y)
+TARGET_CFLAGS+= \
+       -fno-optimize-sibling-calls
+endif
+
 MUSL_CONFIGURE:= \
        $(TARGET_CONFIGURE_OPTS) \
        CFLAGS="$(TARGET_CFLAGS)" \