separate series file fixup from quilt check to avoid series file breakages after...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Oct 2007 15:32:55 +0000 (15:32 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 4 Oct 2007 15:32:55 +0000 (15:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9120 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/quilt.mk

index 667653f..daeef94 100644 (file)
@@ -54,10 +54,11 @@ endef
 QUILT?=$(strip $(shell test -f $(PKG_BUILD_DIR)/.quilt_used && echo y))
 ifneq ($(QUILT),)
   STAMP_PATCHED:=$(PKG_BUILD_DIR)/.quilt_patched
+  STAMP_CHECKED:=$(PKG_BUILD_DIR)/.quilt_checked
   override CONFIG_AUTOREBUILD=
-  $(STAMP_CONFIGURED): $(STAMP_PATCHED) FORCE
+  $(STAMP_CONFIGURED): $(STAMP_CHECKED) FORCE
   prepare: $(STAMP_PATCHED)
-  quilt-check: $(STAMP_PATCHED)
+  quilt-check: $(STAMP_CHECKED)
 endif
 
 define Build/Patch/Default
@@ -119,6 +120,9 @@ $(STAMP_PATCHED): $(STAMP_PREPARED)
                        find * -type f \! -name series | sort > series; \
                fi; \
        )
+       touch $@
+
+$(STAMP_CHECKED): $(STAMP_PATCHED)
        if [ -s "$(PKG_BUILD_DIR)/patches/series" ]; then (cd $(PKG_BUILD_DIR); quilt push -a); fi
        touch $@