linux: disable kmod-zram on ep93xx, it does not export unmap_kernel_range
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2015 21:02:12 +0000 (21:02 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Jan 2015 21:02:12 +0000 (21:02 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44145 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/linux/modules/other.mk

index b2d8eb7..25e0f19 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -748,7 +748,7 @@ $(eval $(call KernelPackage,ikconfig))
 define KernelPackage/zram
   SUBMENU:=$(OTHER_MENU)
   TITLE:=ZRAM
-  DEPENDS:=+kmod-lib-lzo
+  DEPENDS:=+kmod-lib-lzo @!TARGET_ep93xx
   KCONFIG:= \
        CONFIG_ZSMALLOC \
        CONFIG_ZRAM \