strace: move to trunk, add myself as a maintainer
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jun 2014 10:22:18 +0000 (10:22 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Jun 2014 10:22:18 +0000 (10:22 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41097 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/devel/strace/Makefile [new file with mode: 0644]

diff --git a/package/devel/strace/Makefile b/package/devel/strace/Makefile
new file mode 100644 (file)
index 0000000..4c29d69
--- /dev/null
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=strace
+
+PKG_VERSION:=4.8
+PKG_RELEASE:=1
+PKG_MD5SUM:=c575ef43829586801f514fd91bfe7575
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+
+PKG_LICENSE:=BSD-3c
+PKG_LICENSE_FILES:=COPYRIGHT
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+PKG_FIXUP:=autoreconf
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/strace
+  SECTION:=utils
+  CATEGORY:=Utilities
+  TITLE:=System call tracer
+  URL:=http://strace.sourceforge.net/
+endef
+
+define Package/strace/description
+A useful diagnostic, instructional, and debugging tool. Allows you to track what
+system calls a program makes while it is running.
+endef
+
+MAKE_FLAGS := \
+       CCOPT="$(TARGET_CFLAGS)"
+
+define Package/strace/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/strace $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,strace))